Form Tools
Note on installation: step4, step 5 cannot be passed - Printable Version

+- Form Tools (https://forums.formtools.org)
+-- Forum: Form Tools (https://forums.formtools.org/forumdisplay.php?fid=1)
+--- Forum: Installation (https://forums.formtools.org/forumdisplay.php?fid=4)
+--- Thread: Note on installation: step4, step 5 cannot be passed (/showthread.php?tid=1596)



Note on installation: step4, step 5 cannot be passed - Martin - Sep 4th, 2011

Hi all,

I tried to install formtools (core 2.11), but could not get passed step 4.
The window remained empty.
Previously I had to create the config.php manually.
When manually refererring to step5.php I had the same effects.

When continuing and logging in as administrator I also get a blank screen.

I was able to fix this by making the /global directory writable.
After this I could pass all the steps without any problems.

My test configuration:
Mac OSX snow leopard with XAMPP.
Used browsers: Firefox 7.0, chrome 13.0.782.220

Updated: added core revision


RE: Note on installation: step4, step 5 cannot be passed - Ben - Sep 4th, 2011

Hi Martin,

Good *grief*! This used to be an old problem with the older Form Tools 2.0.x, but I thought I had it solved. Apparently not.

Does your database username or password contain any non-alphanumeric characters? Maybe a double quote or dollar sign? Just a hunch... I'm wondering if the validation isn't working properly and allowing you to create a config.php with invalid syntax.

- Ben



RE: Note on installation: step4, step 5 cannot be passed - bvdveen - Sep 4th, 2011

(Sep 4th, 2011, 12:09 PM)Martin Wrote: Hi all,

I tried to install formtools, but could not get passed step 4.
The window remained empty.
Previously I had to create the config.php manually.
When manually refererring to step5.php I had the same effects.

When continuing and logging in as administrator I also get a blank screen.

I was able to fix this by making the /global directory writable.
After this I could pass all the steps without any problems.

My test configuration:
Mac OSX snow leopard with XAMPP.
Used browsers: Firefox 7.0, chrome 13.0.782.220

Hi Ben,

Long time no see! (Meaning Formtools was working fine for a long time)
My problem: after upgradingto ft 2.11, my form with about 355 fields can't get past Step 5. It gives the error: invalid JSON.

and then it gives:

Failed query in ft_finalize_form, E:\AAA\Hortivorm\formtools\global\code\forms.php, line 312:
CREATE TABLE ft_form_4 (
submission_id MEDIUMINT UNSIGNED NOT NULL AUTO_INCREMENT,
PRIMARY KEY(submission_id),
col_1 VARCHAR(20),
col_2 VARCHAR(20),
col_3 VARCHAR(255),
col_4 VARCHAR(255),
col_5 VARCHAR(255),



I have resized most fields to tiny as they are mainly used for measurement units and quantities below 9999. I know this worked before on ft version 2.06.
Waht do you suggest?

Regards and greetings from Cheese Town (Gouda) Holland

Bert van der Veen


RE: Note on installation: step4, step 5 cannot be passed - Martin - Sep 5th, 2011

(Sep 4th, 2011, 3:06 PM)Ben Wrote: Hi Martin,

Good *grief*! This used to be an old problem with the older Form Tools 2.0.x, but I thought I had it solved. Apparently not.

Does your database username or password contain any non-alphanumeric characters? Maybe a double quote or dollar sign? Just a hunch... I'm wondering if the validation isn't working properly and allowing you to create a config.php with invalid syntax.

- Ben

Hi Ben,

I don't have any special characters in my databasename or password. Only the table prefix contains an '_' and the g_root_url contains a ~
(http://localhost/~martin/formtools). This is the only one i can think about causing some trouble.

Martin



RE: Note on installation: step4, step 5 cannot be passed - Ben - Sep 6th, 2011

Hey guys,

Martin - hmm, that won't be the problem, then. But it does sound like there's a problem with the config.php file: if it contains a syntax error it will stop the pages from loading - and it only gets included at that phase of the install procedure.

Could you check your XAMPP PHP error logs? That will almost certainly give a clue as to what's causing the error. This article states where the logs are found:
http://stackoverflow.com/questions/3719549/where-does-the-php-error-log-reside-in-xampp

Bert - good to hear from you! I was in your neck of the woods a couple of months back!

So... at the very end of the error message, does it actually give the you "row too large" message? I wasn't sure from what you posted, or if it was just another error. But if *is* row size, weird though it may seem, you'll actually need to increase the storage size of some fields up to MEDIUMTEXT. Fields that use that storage type (or TEXT) aren't included in the calculation of field size.

- Ben


RE: Note on installation: step4, step 5 cannot be passed - Sacrombie - Oct 19th, 2020

I’ve also tried to install FORM TOOLS in MacOS 2015, but I also found the same error on steps 4 and 6. I got the solution on the help writing a dissertation site, If you want to resolve the issue then, must visit it.