Form Tools
solved: UTF8 special chars, importing ft exports in excel - Printable Version

+- Form Tools (https://forums.formtools.org)
+-- Forum: Modules / Other (https://forums.formtools.org/forumdisplay.php?fid=8)
+--- Forum: Modules (https://forums.formtools.org/forumdisplay.php?fid=16)
+--- Thread: solved: UTF8 special chars, importing ft exports in excel (/showthread.php?tid=202)



solved: UTF8 special chars, importing ft exports in excel - Alexis - Jul 1st, 2009

Hello

I have a problem when importing in excel FT exports. Many of my submissions contain special chars (éàç ....),everything is UTF 8 encoded.

i tried to export in xls and csv format, if i look at the file with a text viewer everything is fine, but if i open it with excel special chars are scrambled (Réanimation Médicale instead of Réanimation Médicale). i could not find the way to import correctly

solved by adding <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
in the headers of the xls file


RE: solved: UTF8 special chars, importing ft exports in excel - Ben - Jul 1st, 2009

Ah, that makes sense. Thanks for reporting the problem + fix.

Since the data is all stored as UTF-8 in the DB, I'll log this as a bug and include a fix for this in the next release (i.e. the export manager export types will have that line in the header section).

- Ben


RE: solved: UTF8 special chars, importing ft exports in excel - coskundemir - Jun 8th, 2013

Hi Alexis,

I owe you a thanks after 4 years your post. I spent a lot of time for this problem. And it is solved by add following code.

Now Turkish Chars are look fine when i export in xls.

That's way to correct problem;

1st Option,

Click blue icon at the right side of the export module under the submission page.

Open Export Manager > Click Edit icon across the Excel line > Main Menu > Smarty Template > Add following code;

2th Option.

Settings > Menu > Edit(click pen icon) > Add Row > Choose Export > Click Update and Refresh page.

Export Manager will appear left side of the page > Click Export Manager Menu;

Click Edit icon across the Excel line > Smarty Template > Add following code;


<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
</head>
<body>

{$export_type_smarty_template}

</body>
</html>


That's all.


Thank you.



(Jul 1st, 2009, 3:42 AM)Alexis Wrote: Hello

I have a problem when importing in excel FT exports. Many of my submissions contain special chars (éàç ....),everything is UTF 8 encoded.

i tried to export in xls and csv format, if i look at the file with a text viewer everything is fine, but if i open it with excel special chars are scrambled (Réanimation Médicale instead of Réanimation Médicale). i could not find the way to import correctly

solved by adding <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
in the headers of the xls file