Form Tools
Sorry, that password does not match. - Printable Version

+- Form Tools (https://forums.formtools.org)
+-- Forum: Form Tools (https://forums.formtools.org/forumdisplay.php?fid=1)
+--- Forum: Installation (https://forums.formtools.org/forumdisplay.php?fid=4)
+--- Thread: Sorry, that password does not match. (/showthread.php?tid=272)

Pages: 1 2


Sorry, that password does not match. - srlaird - Aug 30th, 2009

I made it through the "stuck after step 4" problem by writing my config.php file and uploading it, then skipping to step 5 in the browser. I did have to go into the database with phpMyAdmin and do a change password. When instructed, I deleted the install directory from the server, and was presented with the Forum Tools Administration Panel login. I submit my username and password, and I get the error message "No user account ID was found in sessions. Please log in again below." I keep trying to login, and get "Sorry, that password does not match."

What should I do? I'm stuck (again).

MySQL Version
5.0.45

PHP Version
5.2.5


RE: Sorry, that password does not match. - Ben - Sep 1st, 2009

Haha Smile It happens, no worries.

Resetting the administrator's password can only be done manually. Do you have phpMyAdmin access? If so, you'll need to update the password field in the ft_accounts table for the administrator.

Passwords are encrypted in your database, so you'll need to first choose an encrypt a new password. To do that, just go here:
http://docs.formtools.org/encrypt.php

Good luck!

- Ben


RE: Sorry, that password does not match. - srlaird - Sep 1st, 2009

Thanks for the reply, Ben.

I went into phMyAdmin, and did an insert of the encrypted password in the password field in the ft_accounts table. I also tried inserting the username. I'm not sure I was in the right place. I couldn't tell if it was administrator. I chose admin and active in the dropdown boxes, but it still kept saying client and disabled.

I get this message from the admin login:
"Sorry, your account has been disabled."

I'm not sure the admin password was ever set during installation.

Still Stuck.


RE: Sorry, that password does not match. - srlaird - Sep 2nd, 2009

I started over. I dropped the old database and created a new one. I reinstalled the Form Tools install folder, went to step 4, populated the config.php file and uploaded it, skipped to step 5 in the browser, created the admin account and got to step 6, deleted the install folder on the server, clicked on login and input user and pass. Got this message from the Admin login screen: "No user account ID was found in sessions. Please log in again below."


RE: Sorry, that password does not match. - Ben - Sep 2nd, 2009

Hmmm... it sounds like there may be a more serious problem at hand.

One thing you could try: add this line to your /global/config.php file:

PHP Code:
$g_session_type "database"

Then try re-logging in.

- Ben


RE: Sorry, that password does not match. - srlaird - Sep 3rd, 2009

Ben,

I added: $g_session_type = "database"; to config.php and am now able to log in. Can you explain why? Thanks!


RE: Sorry, that password does not match. - Ben - Sep 7th, 2009

Heya,

Excellent! From what you described, it didn't sound like PHP sessions were working properly. Sessions (in one form other) are a tool used by most scripts out there - they let you store information about a user for the duration of the session. PHP has it's own session management functionality, built into the language - but the support for it is a little patchy. So, I added (well, actually ActiveState did... they supplied the mod!) an alternate version that stores session information in the database.

When you added that setting it just told Form Tools to store user information in the database instead of PHP sessions.

However, do note that you'll have problems using the API with your forms. Right now, the API relies exclusively on PHP sessions. Some chap in the forums posted their mod that allowed it to use database sessions - I'll update the API soon (maybe today, while I remember...).

Sorry... long answer to a short question!

- Ben


RE: Sorry, that password does not match. - srlaird - Sep 7th, 2009

Ben,

Thanks for the explanation. You are correct: I can't initialize a form using the API method. So, please send the work-around for that as soon as you are able.

Are API functions the only way to pull data out of the tables for display on a web page? I want to write several PHP functions to view and edit table contents from web pages. Is there an easier way to do what I need to do?


RE: Sorry, that password does not match. - andrejj - Sep 13th, 2009

(Sep 2nd, 2009, 9:29 PM)Ben Wrote: Hmmm... it sounds like there may be a more serious problem at hand.

One thing you could try: add this line to your /global/config.php file:

PHP Code:
$g_session_type "database"

Then try re-logging in.

- Ben

Hello
After updating core to 20090908 previous working environment got me to same issue. Even adding line you suggested to config.php is not helping. Only solution so far was restoring.

Andrej


RE: Sorry, that password does not match. - Ben - Sep 13th, 2009

Hi Andrej,

Did you update the core and the API as well?

- Ben