The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Thankyou page not displaying. blank page with url of original page

Any chance you could give me temporary FTP access so I can log on and take a look at the problem directly? I bet it's something simple (e.g. in the second chunk of code you quoted, with the final "no_sessions_url" line commented out, the previous "finalize" line *shouldn't* have a trailing comma!).

If so, email me at - if not, let me know and we'll figure something out!

- Ben

I'm not sure how to give you temp access. Could I email you the files themselves to look at?
Do you meen access to form tools or to the entire site?
Sure! You could just email me the files & I could take a look.

Also one tip I should have mentioned: if you haven't already done so, add this to your /global/config.php file:

PHP Code:
$g_default_error_reporting 2047

That will output all errors/warnings/notices that occur. You should probably remove it when you're done, but I find it invaluable for debugging.

- Ben
Great! I just e-mailed you the entire form, as well as the SDK.
I admit I get a little lost trying to decipher all the additional files. It is starting to make more sense as I go along. I have only started to attempt any coding with php in just the last few weeks. So I am yet a wee babe in the world of php. Smile
OK, now my other form that was working fine is doing the exact same thing. Nope it seems to be working now?????
Also when I just tried to log into my formtools admin with the error reporting enabled as suggested above I got this message;

Notice: Undefined index: is_beta in /home/sciente2/public_html/formtools/global/code/upgrade.php on line 419

Notice: Undefined index: is_beta in /home/sciente2/public_html/formtools/global/code/upgrade.php on line 422

Warning: Cannot modify header information - headers already sent by (output started at /home/sciente2/public_html/formtools/global/code/upgrade.php:419) in /home/sciente2/public_html/formtools/global/code/accounts.php on line 201

Maybe something got corrupted in my formtools installation?
Problem solved!!!
Listen up if you have had the same type of problem. Check your auto-respond e-mail settings in formtools.
It was because my auto-respond e-mail that you set-up in formtools was corrupted somehow. My modem crashed while I was working on it, and that must have caused some corruption in the e-mail settings or something. But it was hanging at the section of the api.php where it sends out the e-mails after submitting the data to the database.
Hope this helps out anyone else that runs into a weird error while the code looks good.
Probably only a one-in-a-million type thing though.
Thanks to Ben who spent the better part of the afternoon trying to help me solve this via email.
Kudos to Ben for his awesome support and attitude.

Forum Jump:

Users browsing this thread: 1 Guest(s)