The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Chrome, Firefox aren't using css? (CLOSED)
I discovered that only IE8 displays Form Tools correctly. Chrome 8 and FF 3.6.13 don't seem to be using the css (default or any other). Any thoughts? I tried reinstalling and no luck. Everything else seems to work as expected, just looks ugly. Searched forums various ways, but no luck finding any fix for this. Screen capture attached. Any help would be appreciated.

My config:
Apache/2.2.14 (Win32)
MySQL: 5.1.41

Additional problem discovered (related to install?):
Swift Mailer -- Cannot update fields unless I click Update first. Even then clicking "Advanced Settings" does nothing. This happens in Chrome, FF, and IE8. I get no errors except in IE8 where I get an error on just every page. When I select the module, I get this error:

Message: Unterminated string constant
Line: 33
Char: 96
Code: 0
URI: http://mcmdev.local/_private/formtools/m...e=settings

When I Update, I get the previous error plus this error:

Message: 'rules' is undefined
Line: 273
Char: 1
Code: 0
URI: http://mcmdev.local/_private/formtools/m...e=settings

I get other error messages throughout the process. In the end, I can successfully send e-mail, but something isn't quite right.

Attached Files Thumbnail(s)
This same issue has come up with my installation of Drupal. The user interface works fine in IE, but Chrome and Firefox don't seem to use the css.

Being new to this forum and to Form Tools, does anybody have any ideas what might cause a problem such as this? Since it now appears to be something not specific to Form Tools, I'm having no luck resolving this. The rendering problem in Form Tools is also causing usage issues where links overlap and some don't work at all. I really don't want to use IE.

It hasn't been a problem for my own website or any that I browse across all the browsers. It's only an issue for these two products so far.

I have uninstalled and reinstalled Form Tools a couple of times to see if that would correct the problem, but no luck.

Any help would be greatly appreciated. Thanks!
Apologies if this is a silly question, but is it possible that Firefox’s settings are overriding the CSS? Check under Tools > Options > Advanced.
Buttons -- You got me looking in a new place and I finally found the problem. I've been searching forums endlessly and nothing was solving my problem. Although your suggestion didn't result in a solution, I went back to the Firefox forum and pinpointed the problem to my local server config. After updating the php.ini default_mimetype from the default of "text/html" to "", it worked. Unfortunately, when I checked my host server, it is set to the default so I'll have to resort to using/updating a .htaccess file for Form Tools, Drupal, and Joomla. I knew it had to be environmental once Drupal and Joomla started showing the same problem.

The mystery was trying to figure out why it was a problem with Chrome and Firefox and not IE. Being stuck on that prevented me from finding the solution. Actually, it did turn out to be a problem with IE. Firefox and Chrome follow the standards for handling MIME types and IE 8 still doesn't. Apparently this will be corrected in IE 9. If all three browsers didn't work, I might have been able to narrow the problem down better.

I'll chalk it up to my first experience of developing on my own localhost. Live and learn.

Well, I’m glad you found the answer, even if the explanation was far from what I suggested. And who would have thought it’s yet another case of IE failing to follow standards?

I hope your experience may help others who find themselves in the same position.
Looking in Firefox help I found this;

"Page styles disabled

You may have inadvertently set the page style to "No Style." To ensure Firefox is set to use the page's default style:

* At the top of the Firefox windowOn the menu bar, click on the View menu, then select Page Style, then click Basic Page Style.

Now that the page is using its default style, it may be displayed correctly.
Old version cached"

When I switched it to "no styles" it rendered the page in the same fashion that your attached pic shows. Could that have something to do with it?

Forum Jump:

Users browsing this thread: 1 Guest(s)