The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Upload File Problems
I tried to read through the Forums to fix all of this on my own.. However, nothing mentioned seemed to work.

The closest one was the one that referred to "tweaking" Windows.

When I try to upload a file (either from the form or editing the submission) I get this error:

Warning: rename(C:\WINDOWS\Temp\phpD071.tmp,E:\inetpub\vhosts\\httpdocs\form_tools\formtools\upload/resume_laskillern.doc) [function.rename]: Permission denied in E:\inetpub\vhosts\\httpdocs\form_tools\formtools\global\code\files.php on line 462

Notice: Undefined offset: 2 in E:\inetpub\vhosts\\httpdocs\form_tools\formtools\process.php on line 249

Warning: Cannot modify header information - headers already sent by (output started at E:\inetpub\vhosts\\httpdocs\form_tools\formtools\global\code\files.php:462) in E:\inetpub\vhosts\\httpdocs\form_tools\formtools\process.php on line 286

Notice how the slash problem has come up again.. I tried every form and way to update the slashes and it really didn't matter...

It *appears* that the issue has to do with renaming the file from the Temp File to the FileServer file.

Permissions have been completely granted to allow access to the uploads directory.

Please let me know what other details I can supply to try to get this resolved.

I love this tool, I love this product.. I just need to be able to upload a file from a form. Smile
Hi Kim,

Sorry you're having trouble!

To be perfectly honest, there's a LOT of things that can go wrong with file uploads (permissions, file types, file sizes, forms not includes enctype attribute and more), and it's difficult to providing decent feedback to explain what's the most likely cause of the trouble. What I usually suggest is first try uploading a file through the Form Tools UI for any submission currently in the database. If that doesn't work, we can at least eliminate a misconfiguration in your form.

But judging from the error message, most likely that problem is caused by the permissions being set incorrectly on your /temp folder. Are you running your own server or is it hosted by a separate company? If it's local, try just changing the permissions on the /temp folder to allow full read-write permissions. If it's hosted elsewhere, try firing off an email to the hosting company to ask them if the file is read-writable.

Let me know how it goes!

- Ben
Hey Ben -

Thanks for your help!

I can not upload a form from the form tool database (post submission) page either, so we can rule out that possibility for now.

I'm not sure where the temp directory is coming from.. I had assumed that it was coming from my personal computer since it is referencing the C drive instead of the E drive (which is where my documents are located on the webserver). Is there a way for me to set that temporary directory in my form itself? I'll do a search on that and see.

I am running this on a hosted webserver and I have verified that the mode is set to 777 on all of the directories that I am working with.

I think we can also rule out sizes, types and encryption types at the moment. Everything is set to the default value.

Let me know if you have any other ideas, in the meantime I'll see if I can figure out if this is a temp directory on the hosting server rather than my personal temp directory.

Hey Kim,

No worries!

Actually the /temp folder is something that's specified in the php.ini file on your web server; it can't be set by the form itself - so you'll need to bug your hosting provider for that! It's *possible* it's not the cause, but it's my best guess right now. Let's see what they say about it and if no luck, we'll go from there.

Speak soon -

It turns out that was the problem. Thank you so much for your help! I am all set and ready to go!
Thanks for letting me know!

Have fun with it! Smile

Forum Jump:

Users browsing this thread: 1 Guest(s)