FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 2 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Email notification of form submission, not working!
#1
Hi there,

I've been using form tools and previously was able to receive email notifications of form submissions, but it's no longer working for me.

I've configured all the settings in the "EDIT EMAIL TEMPLATE" section, but no matter what I do, I don't receive the notification email any longer.

Is there problems with this feature now, or any ideas on what I might be doing wrong / a setting I'm missing etc?

Please help - I rely on this feature for new form fills!

Thanks,

L.
Reply
#2
Are you using swift mailer extension ?
Reply
#3
(Jan 20th, 2016, 9:09 PM)alexh Wrote: Are you using swift mailer extension ?

No, just the form tools install as is...
The strange this is the test email work fine (with in the formtools admin). It's only when I actually submit a form, that it doesn't notify by email that there's been a new form submission.

I've configured the recipients (added the email address) in formtools admin, but still nothing.

Any ideas?
Reply
#4
Not going to be much help here ... but I have the same issue.
Using send test email works great. But when I submit a form through the site, the submission gets added to the database but doesn't send an email.

Configuration:
Enabled
On Form Submission


Recipients(email accounts both exist at can send receive):
My email
Sender:admin email account



Test:
Send test email works



Edited: Used Swift mailer which solved the problem
Reply
#5
Same Problem here...
Test email works fine, submitted forms are shown in the database, but no notification goes out.
If I switch to swift emailer, test emails from the swift module again work fine, but I get an error message from the form tools website when I submit a form from my website.
Any help available?
Thanks,
Stefan
Reply
#6
Sad 
It's now mid-April and there's still no resolution to this problem. Is there anyone out there from the developer that can help?
Reply
#7
I am suddenly having the same problem here. Been using FormTools for a couple years and emails go out when form is submitted. Last week ALL emails stopped. Results show in database but NO EMAILS . . . even to myself. I am using 2.0.5 version on a PLESK Debian server. Can anyone help us? Thank you . . .
Reply
#8
Same problem, test works fine, as long as I pick html only or text only... but form upon submission are there is no alert emails sent?
Reply
#9
I have some more details on the issue.

I use the Form Tools 2.2.5 with the standard php mail function, no module.

I have some "normal" forms. For sending the form as e-mail I have defined a HTML template and a text template as well.

While using PHP 5.3, it works well, and mails are sent.

If I switch to PHP 5.5 or 5.6, the user doesn't see a difference, but the mails won't be sent. Also the test mail shows an sending error, if I choose HTML & Text as mail format. If I choose HTML only or text only, the test mail will be sent.

If I delete the text template, mails are sent also with PHP 5.5/5.6.

It seems, that there's an issue with multipart mails in PHP 5.5+.
Reply
#10
Thanks to this post, I got an idea on how to work around the emails no longer forwarding...

When you are configuring the email notification set up, under the 'Content' tab there are options on what to display for both HTML and Text emails. Now, after using form tools since I started coding web sites almost a decade ago, out of habit I would fill out the content for both versions.

Based on what was said in this post, I tested emails for ONLY HTML and ONLY text, and the tests went through no problem. So I thought what would happen if I only submit content for HTML template only? And IT WORKED! The form I'm using this for only goes to me and the client anyway, so I know HTML is what we are receiving and would work just fine.

Not sure if this is the solution that will fix it for everyone, but it's worth a try. Form tools is the BEST out there for forms and I was incredibly sad when the email notification stopped working. So far it's working just like it used to with this work around -- so hopefully someone else will give it a try and see if it helps them be able to use this tool still.

p.s. - SwifterMail was enabled, even though I spent so much time seeing if that was the problem like a few others mentioned on the forum to no avail.
[/align]



(Jul 27th, 2016, 2:58 PM)Sportmin Wrote: I have some more details on the issue.

I use the Form Tools 2.2.5 with the standard php mail function, no module.

I have some "normal" forms. For sending the form as e-mail I have defined a HTML template and a text template as well.

While using PHP 5.3, it works well, and mails are sent.

If I switch to PHP 5.5 or 5.6, the user doesn't see a difference, but the mails won't be sent. Also the test mail shows an sending error, if I choose HTML & Text as mail format. If I choose HTML only or text only, the test mail will be sent.

If I delete the text template, mails are sent also with PHP 5.5/5.6.

It seems, that there's an issue with multipart mails in PHP 5.5+.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)