FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Language doesn't load
#1
Hi all!

This is a new problem I guess...since there isn't that many languages available yet :-)

I have finished translating FT 2 into Swedish and downloaded the languagefile from the language repository but I can't get it to change language.

Yes, the file is placed in /global/lang/
Yes, it shows up and is set in the lang popup under "Your account" and "Settings - Accounts"
Yes, I have restarted my browser.
Yes, I have tried chmod it to 644 (like en_us.php is)

Any suggestion on what to do next?

Best regards,

Peter
Reply
#2
Wow! Excellent, thanks Peter.

Would it be possible for you to send me the file? The language functionality is pretty untested right now so I'll install your file locally and see what's going wrong.

- Ben (formtools@encorewebstudios.com)
Reply
#3
Ah! Never mind. I didn't realize you were using Open Translate.

I'll install it and get back to you soon.

- Ben
Reply
#4
I've been looking into this. It's actually a non-trivial problem; part of the code was simply out of date, which was easy to fix, but there's a nagging problem left over... I'll post back when I've come up with a fix.

- Ben
Reply
#5
(Apr 27th, 2009, 7:22 PM)Ben Wrote: I've been looking into this. It's actually a non-trivial problem; part of the code was simply out of date, which was easy to fix, but there's a nagging problem left over... I'll post back when I've come up with a fix.

- Ben

Excellent Ben.
Another thing... I had a couple of translation questions which I posted there. If you have the time, could you take a look?

//Peter
Reply
#6
Will do, Peter. I'll try and get to it tomorrow night (darn day job! ;-))

Today's build contains the fix for the language files so that it's at least showing up. However, the language file contents were slightly outdated so when you log back into Open Translate you'll see a few more lines to translate. Very few - under 10, I believe.

When returning to FT2, you'll need to download the latest translation file from: http://translations.formtools.org.

I'll be reviewing the whole translation component soon. No doubt there are bugs to solve...

Anyway, again, thanks for your help translating. It's MUCH appreciated!

On a sidenote, I'm planning on update the Custom Build feature (http://ft2.formtools.org/build/) to include the language packs, too. That way people can use the entire script - including the installation - in the language of their choice. Your work will really come in handy.

- Ben
Reply
#7
Ben,

I'm also having problems with getting the translation file to load.
As it said in the "how to Install" I uploaded nl.php to "/global/lang/" under the formtools root folder and set the account language to Dutch, but the interface remains in English.

Can you assist?

Kind Regards,

Sam
Reply
#8
Hi Sam,

So you changed the account language to "Dutch" via the "Your Account" navigation page? This one trips me up too - it needs to be set in two places: one for the client accounts and one for the administrator account.

Let me know how it goes. If you're still having trouble I'll test things out locally and see what's up. Smile

- Ben
Reply
#9
Hi Ben,

I did change the account language to "Dutch", for both admin and clients. And the file is uploaded to the proper location. I can't see what I'm doing wrong...

Kind regards,

Sam


For testing purposes I tried to install the swedish language file and see if that one works. After installing and changing the language settings, nothing changed. Either sth 's wrong with my specific installation (v2.0.0-beta-20091101), my setup (however config.php seems correct) or sth else's wrong...
Reply
#10
Same here with the Italian translation. File is on the right place, and configuration is fine. Logged out and in again - but everything is still in English.

This bug must be squashed...
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)