FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
checkbox values not appearing in database, only commas
#1
Sad 
OK, after a long, hard journey I finally got this form working as desired, (thanks again to Ben for his time and effort Smile).

Now I only have one small issue, checkbox values are not being displayed in the database, just a series of commas for each selection made. The values are being uploaded because they appear correctly in the e-mail sent upon submission.

Now before any body asks,
Yes, the name attribute of the arrays have the []
Yes, the database fields and views are set to maximum (VERY LARGE)
I've tried both horizontal (preferred) and vertical views, same result.
Yes, I looked through almost EVERY single post in the forums to find an answer before posting,(wish more people would do that, it would cut down on the repetative questions).
So now I'm asking for any tips.

As a side thought, I know that often questions are posted in the midst of confusion and frustration, but PLEASE people, when posting questions or answers, be descriptive in the thread subject title. Subject titles such as "Help" or "How can I fix this" or "Problem with form"
are next to useless to others looking for help or trying to provide help.
I feel sorry for Ben as he has to sort through numerous questions and has to open each post to see what someone is actually talking about.
I have been on other forums where such vague subjects are just deleted because they waste the admins time as well as others looking for help or providing help.
Ben maybe you could stress the need for more concise thread titles to make the forums easier to utilize.

Thanks in advance Smile
Reply
#2
Hi Jeff,

Sounds like you're definitely making progress though!

If you just see a series of commas that's actually half good. It means that the script was able to understand that your field has multiple values (so the [] characters are doing their thing Smile ), it's just that it doesn't find any actual values to store for those selected options.

Did you check the actual Field Option Group section? Make sure that for the Field Option Group being used by your field has values in both the Field Value AND Display Text columns options. If they don't have any, they'll just show up as a series of commas like that. Check this page for some related info:
http://docs.formtools.org/userdoc/?page=fog_editing

That might not be the cause, but it's my best bet!

All the best -

- Ben
Reply
#3
DOH!!!!
That was it. Thanks Ben, again.
Ya know it's been the little obvious things that have been more problematic than anything else.
But now I have all the forms up and live. thanks.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)