FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Swift Mailer Module & Gmail SMTP
#11
If you're getting the connection time out error, then the port is probably not as open as the web host says it is. I would ask them again and this time ask them to open the port for ALL outgoing connections. Then test it again. Let us know!
Not a FT employee, just a FT user lending a hand. If I've been helpful, please rate.

[Image: giraffe_long_85.gif]
Reply
#12
Michatmaster7 - I keep going back and forth with them - still awaiting a further response. They say it is open to "their" smtp server, and we keep playing word games with what an outbound smtp server is. I've given them the info to test with and they haven't gotten back yet. I'm beginning to think it's time to change hosts... This is the proverbial straw. It is NOT difficult people!! LOL!! The error log suggest that it is puking at line 309 of smtp.php, and that is where it connects. It doesn't appear to be programming or a bug, but rather an host issue. Thanks guys!! I'll let you know if they resolve it or not. If not, I'll let everyone know who they are and NOT to use them.

Peace,

Bill
Reply
#13
(Aug 1st, 2012, 8:25 AM)BillDOH Wrote: Michatmaster7 - I keep going back and forth with them - still awaiting a further response. They say it is open to "their" smtp server, and we keep playing word games with what an outbound smtp server is. I've given them the info to test with and they haven't gotten back yet. I'm beginning to think it's time to change hosts... This is the proverbial straw. It is NOT difficult people!! LOL!! The error log suggest that it is puking at line 309 of smtp.php, and that is where it connects. It doesn't appear to be programming or a bug, but rather an host issue. Thanks guys!! I'll let you know if they resolve it or not. If not, I'll let everyone know who they are and NOT to use them.

Peace,

Bill
I found the issue to be a mail issue with an outside provider. This script works perfectly on all of my other installations and with this same host or others. Jamming work! I truly appreciate the contribution to the community and the help available.

Cheers and May God Bless you all!

Bill
Reply
#14
Could you clarify what you mean by an outside provider? So the port WAS open at the host and it was not a hosting problem? I'm still confused on what the resolution was...
Not a FT employee, just a FT user lending a hand. If I've been helpful, please rate.

[Image: giraffe_long_85.gif]
Reply
#15
(Aug 30th, 2012, 10:08 AM)michatmaster7 Wrote: Could you clarify what you mean by an outside provider? So the port WAS open at the host and it was not a hosting problem? I'm still confused on what the resolution was...

The resolution was an MX entry in the DNS. Mail was being handled by the server locally instead of remotely so mail going to a local address (that didn't exist locally) was not forwarded to the proper mail server. In this case, we use mailhop.org for mail relay to an exchange server. No valid email addresses are located on the local mail server, which the web server is configured by default to direct mail to (the local mail.domain.com POP/SMTP). Hopefully this clarifies it.

Reply
#16
There was a problem communicating with SMTP: Authentication failed using username 'app@programs.my' and password '************'

Its been a week and was working perfectly earlier. Nothing was changed before the failure occurs. It just happens. Updated Swift mailer module (same version) as before, just in case, there's corruption in the codes.


My installation:
Form Tools Core Version: 2.2.5
Core Version Upgrade Track: 2.2.5
API Version: 1.1.4
PHP Version: 5.3.19
MySQL Version: 5.1.68-cll
PHP Sessions: Available
Suhosin Extension: Not Installed
Curl Extension: Available
SimpleXML Extension: Available
____________________________________
MODULES (name, version, enabled)
Core Field Types, 1.0.2, Yes
Export Manager, 2.1.1, Yes
File Upload, 1.1.0, Yes
Pages, 1.2.6, Yes
Swift Mailer, 1.1.2, Yes
System Check, 1.0.3, Yes
TinyMCE Field, 1.0.8, Yes
____________________________________
THEMES (name, version, enabled)
Classic Grey, 1.1.3, No
Default, 1.0.0, Yes
Reply
#17
To chalorlay - Your issue is different than than my reply, but it sounds like the authentication types or criteria have changed, if not by you, then perhaps by the host you are connecting to.

For everyone else getting the fsockopen error. I recently was tasked with installing FormTools on several additional webs I admin, to replace outdated FrontPage forms. On my first attempt I started getting this error again, when trying to connect to gmail via SMTP. I tried different encryption methods and different ports, to no avail.

I contacted the host who told me that the ports were open for external connections and they verified the server's firewall was not blocking those ports.

The weird thing is that I have two FT installs on a dedicated server that work without question. One of them is connecting to gmail via SMTP, and has no trouble. But for some reason I am getting this error on our shared server.

As of just this moment, after learning that fsockopen is actually a specific module of PHP, I discovered that the fsockopen module had not been enabled on our server.

You can test this on your server by uploading a .php file with the following code:

PHP Code:
<?php
if(function_exists(‘fsockopen’)) {
echo 
"fsockopen function is enabled";
}
else {
echo 
"fsockopen is not enabled";
}
?>

I found this info from here: http://kb.siteground.com/how_to_check_if...he_server/

My WebHost informed me that I could upload a file with the name of php.ini to the root, with custom PHP settings for that website.

I will update with the exact contents of the php.ini file when they reply.
Not a FT employee, just a FT user lending a hand. If I've been helpful, please rate.

[Image: giraffe_long_85.gif]
Reply
#18
It has now been two full days of troubleshooting. The only difference I've been able to find between the FT install on my dedicated server and the install on my shared server is the version of PHP being used. The version that is working is 5.2.17, while the PHP version that is not working is 5.3.22.

Between the host and myself, we have checked every nook and cranny we can find. SwiftMailer is still refusing to connect to smtp.gmail.com using PHP 5.3.22. I have to believe that the FT code needs to be updated (or maybe a new version of the SwiftMailer module needs to be released) in order to remedy this and get it working again.

Message from the WebHost:

Quote:I am not familiar with the SwiftMailer application itself, but it looks like either the mail needs to have a "from" of the server it is executing on, or something in its code needs altering as the management interface does not apply the settings correctly.

Here are a few posts I found outlining what I came across leading me down the above thoughts.

http://swiftmailer.org/docs/sending.html#encrypted-smtp

http://stackoverflow.com/questions/35368...l-smtp-php

http://stackoverflow.com/questions/99734...nied-error

http://forums.formtools.org/showthread.php?tid=129

Hoping that Ben or Joe is watching the forum about this. I'm exhausted from trying to make this work.
Not a FT employee, just a FT user lending a hand. If I've been helpful, please rate.

[Image: giraffe_long_85.gif]
Reply
#19
Post #17.
Its been 2 weeks since the failure.

Done changing the permission to directories and files to 755 (probably increased the vulnerabilities to abuse). Nothing.
Done discussions, lots of email with webhost, ie insisting that everything works fine and well on their side.

Last attempt (host admin's suggestion), create new Gmail account and reflect the new account in Swift Mailer module setup. Suddenly it simply works.

Don't know what happened. Satisfying my curiosity, change back to the old Gmail account and Swift Mailer also works.

Conclusion (IMO & my unique case),
Error got nothing to do with Swift Mailer codes.
Also nothing to do with my Gmail account
Most probably, the hosting and setting changes made by my host's admins (not admitting to it! they did email me to retry using new Gmail account and I did + works. Old account also works). I'm positive they did something!.
Reply
#20
Is your PHP version still 5.3.19? I'd find it interesting to know that SwiftMailer is working for you on 5.3.19 and not for me on 5.3.22.

(Mar 14th, 2013, 12:07 PM)chalorlay Wrote: Post #17.
Its been 2 weeks since the failure.

Done changing the permission to directories and files to 755 (probably increased the vulnerabilities to abuse). Nothing.
Done discussions, lots of email with webhost, ie insisting that everything works fine and well on their side.

Last attempt (host admin's suggestion), create new Gmail account and reflect the new account in Swift Mailer module setup. Suddenly it simply works.

Don't know what happened. Satisfying my curiosity, change back to the old Gmail account and Swift Mailer also works.

Conclusion (IMO & my unique case),
Error got nothing to do with Swift Mailer codes.
Also nothing to do with my Gmail account
Most probably, the hosting and setting changes made by my host's admins (not admitting to it! they did email me to retry using new Gmail account and I did + works. Old account also works). I'm positive they did something!.


I have just tested SwiftMailer with smtp.com (I forgot I had an account I could use for testing. I got the same errors. So it's not just Gmail in this case, the problem is simply that I can't use any external smtp configurations. It works when using local smtp settings (ie: using an e-mail address located on the local server), but that isn't what I need to do...
Not a FT employee, just a FT user lending a hand. If I've been helpful, please rate.

[Image: giraffe_long_85.gif]
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)