FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Installation on windows 10
#1
With IIS and PHP 7.0.7..

When I called FormTools/install/index.php,

there is only a blank screen.

I set the security for themes/default/cache to "full control".

Still, only a blank screen.
Reply
#2
Your problem is with PHP7, the way that PHP executes its calls to MySQL has changed. And Form Tools is not compatible with PHP7 drop to the latest version of PHP5 and it should work for you. PHP5 will continue to receive security updates for the next 3 years.

(Jun 8th, 2016, 6:39 PM)manigrid Wrote: With IIS and PHP 7.0.7..

When I called FormTools/install/index.php,

there is only a blank screen.

I set the security for themes/default/cache to "full control".

Still, only a blank screen.
Reply
#3
Thanks for the response. I suspect that it has to do with the version of PHP. I will downgrade to PHP5 and see what happens.

Is FormTools going to do any upgrades?




(Jun 16th, 2016, 8:52 AM)paullittrell Wrote: Your problem is with PHP7, the way that PHP executes its calls to MySQL has changed. And Form Tools is not compatible with PHP7 drop to the latest version of PHP5 and it should work for you. PHP5 will continue to receive security updates for the next 3 years.

(Jun 8th, 2016, 6:39 PM)manigrid Wrote: With IIS and PHP 7.0.7..

When I called FormTools/install/index.php,

there is only a blank screen.

I set the security for themes/default/cache to "full control".

Still, only a blank screen.

I downgraded to PHP5, but still get a blank screen. I have not go to the first screen or even before access to MySQL or even the first setup screen.

I have installed as a fastCGI with IIS.

IIS is on Windows 10.
Reply
#4
One way to test if it is your IIS setup would be to download WAMP, as I know the default configuration of WAMP with PHP5 will run it right out of the box, as this is how I sandbox Form Tools to make and test custom code changes.

(Jun 17th, 2016, 6:18 AM)manigrid Wrote: Thanks for the response. I suspect that it has to do with the version of PHP. I will downgrade to PHP5 and see what happens.

Is FormTools going to do any upgrades?




(Jun 16th, 2016, 8:52 AM)paullittrell Wrote: Your problem is with PHP7, the way that PHP executes its calls to MySQL has changed. And Form Tools is not compatible with PHP7 drop to the latest version of PHP5 and it should work for you. PHP5 will continue to receive security updates for the next 3 years.

(Jun 8th, 2016, 6:39 PM)manigrid Wrote: With IIS and PHP 7.0.7..

When I called FormTools/install/index.php,

there is only a blank screen.

I set the security for themes/default/cache to "full control".

Still, only a blank screen.

I downgraded to PHP5, but still get a blank screen. I have not go to the first screen or even before access to MySQL or even the first setup screen.

I have installed as a fastCGI with IIS.

IIS is on Windows 10.
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)