FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
No user account ID was found in sessions. Please log in again below.
#1
No user account ID was found in sessions. Please log in again below.

After installing form tools and finishing the last step. It request that the install folder be deleted before attempting to log in. I deleted my install folder and then attempted to login I got the error up above (No user account ID was found in sessions. Please log in again below. ).

I also had to manually create my config.php file.
<?php

// main program paths - no trailing slashes!
$g_root_url = "http://www.mysite.com/formtools";
$g_root_dir = "/hermes/bosweb/web284/b2848/ipw.myaccount/public_html/formtools";

// database settings
$g_db_hostname = "myaccount.ipowermysql.com";
$g_db_name = "mybd";
$g_db_username = "myusername";
$g_db_password = "mypassword";
$g_table_prefix = "ft_";

?>

I can not login at all could anyone please suggest how to correct this issue.

Everything seem to be installed correctly, just unable to log in for the first time.


Attached Files Thumbnail(s)
   
Reply
#2
Hi gonzo,

Huh! Form Tools uses sessions to temporarily store information about the user currently logging in, so it's quick & easy to access. For whatever reason, it appears that the sessions aren't being set properly.

It's possible that PHP sessions aren't enabled on your system... but it would seem unlikely. Maybe try this instead. Add this line to your /global/config.php file:

PHP Code:
$g_session_type "database"

Then try logging in again. Any change?

- Ben
Reply
#3
Hi all,

There was no response as to whether this worked or not which is not very informative to users seeking answers to the same question. It worked like a charm.

Just wanted to say a quick thanks to you Ben for always being there despite battling a hectic schedule.

Thanks. Much appreciated.
Reply
#4
No worries, thanks for your kind post. Smile Hope it helps other people out too.

- Ben
Reply
#5
Hi Guys!

I have similar problem. But the above solution did not help.
I added this line :
$g_session_type = "database";

and no difference, I am being logged out every time I try to switch between tabs on the "edit submission" page or if I try to switch between different views using the drop-down menu in the top right corner.

I upgraded from 2.0.4 to 2.1.9 and problem remains unsolved.
I also moved to a different server and still nothing.
It only happens on the form that has over 3300 entries.
The other forms with just a few entries work fine.
Can anyone help, please?

Thanks
Kris

P.S.
Ben!
I must admit, you're a genius! I love formtools. Thanks so much for al your work. I learned a lot from you.



Reply
#6
Hi Kris,

Quote:It only happens on the form that has over 3300 entries.

Interesting clue. So it's probably caused by sessions, yes... Could you look at your phpinfo() setting and see if you have an extension called "suhosin" installed? (Just upload a php file with <?php phpinfo(); ?> in it, and load it in your browser to see).

Just a hunch, but I wonder if your session sizes are being capped.

- Ben
Reply
#7
Hi Ben!

Thank you so much for your reply!

No, there's no suhosin.

would this help?:
[Image: pic.png]

Thanks
Kris
Reply
#8
Hey Kris,

Again, sorry for the wait... I just haven't had any time to help out in the forums for a while now!

Thanks for posting the screenshot, but I don't see anything there that would be causing your problems.

Any chance I could get temporary FTP access to your Form Tools folder so I could log in and debug the problem directly? If so, email me at ben.keen@gmail.com with a link to this thread. I'm pretty sure it's a server issue, but I don't know exactly what yet.

- Ben
Reply
#9
HELP!

My formtools was working fine yesterday. Then today I went to log in and it wouldn't let me. I didn't get an error but the address bar kept showing no_account_id_in_session. I found this thread and inserted the line of code into my config file. I was able to log in but...

Any time I try to view a submission it just shows empty fields that are all greyed out! I noticed that there were a couple of upgrades available (I was using 2.1.6. I downloaded all of the upgrades but it didn't help.

Apparently the data is still there and I can still submit forms. So this is good.

*** UPDATE ***

Everything is working fine. Apparently there was an error on my hosting account that wouldn't even let me sign into phpMyAdmin. Once that was resolved everything was working fine again except the blank entries that were submitted while the database was down.
Reply
#10
Hi Guys

Sorry I just realised I never actually responded back with info how I solve this problem.
Hopefully someone will find it useful.

To solve this I had to identify proper php sessions path and and also changed session.use_trans_sid value from 0 to 1

In my php.ini before i had (refer to screenshot I posted above before):
session.save_path no value
session.use_trans_sid 0

now I have:
session.save_path /home/users/myusername/phpsessions
session.use_trans_sid 1

After this no more problems :-)

for some of you setting session.save_path to /tmp may help to

Kris
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)