FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
2 issues: MySQL version and Swift Mailer (could be interrelated)
#1
Hi everyone,

Ben here again from fauvdesign (had the recent email issue that was solved with Swift Mailer).

Having more issues with the same server (bloody Windows servers) but a different domain:

http://www.redrockmortgages.com.au/home-...submit.htm

The installer said the MySQL was an old/invalid version (even though in the Plesk backend the version was above required). It gave me the option of clicking Ignore, so I did, but it might be contributing to the following issue.

I'm not receiving any emails through Form Tools, no Swift Mailer or PHP Mail, no test emails or otherwise. Currently I've set it up with Swift Mailer, and it says it's sent the test email but I haven't received it.

Would be great to get some help on the issue!
Reply
#2
Hi fauv,

Oof, you do seem to run into trouble!

Do you recall what it said for the MySQL version? Was it MySQL 3, 4 or 5? The existing MySQL version detection code gets confused if it's not a standard formatted string [just FYI, I've updated this in the latest alpha, which should reduce the number of "invalid version" detections here on out].

But if it thought it was version 3, then that's the version that PHP thinks that is installed: that can be bad. Even if the MySQL version is something different, PHP thinks otherwise and it can lead to problems. If I were you, I'd take a look at your phpinfo and see what version is says there. (To do this, just upload a phpinfo.php file to your server with this is in it: <?php phpinfo(); ?>

So, emails...

Hmm. I think I'd look into the logs. Many servers keep error logs and logs the emails sent out. Do you know if your server has either?

- Ben
Reply
#3
Hi Ben,

Thanks for the reply! I forgot to edit my post to say that the issue was resolved - there was an issue with the guys who run the server. Once they fixed it, all was fixed. So glad, all this other stuff was way over my head.

So it wasn't a problem with FormTools, but with some recently changed server settings which had affected the forms on all my clients domains!
Reply
#4
Excellent! Glad it's all working properly now. Smile

- Ben
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)