FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
expression is too large at offset ...
#1
I get this warning on stage 6 during installation of 2.1.0 beta:

"Warning: preg_replace() [function.preg-replace]: Compilation failed: regular expression is too large at offset 1048589 in C:\wamp\www\bible\global\code\hooks.php on line 445"

How should I rectify this problem?
Reply
#2
Huh! Let me test it out and see if I can reproduce it. I'll get back to you.

- Ben
Reply
#3
Hi Victory,

That section that it's complaining about *is* new code, so it's possible there's something wonky going on there. What's happening is that on installation, Form Tools 2.1 parses the entire code base and extracts and makes a note of all hooks then stores them in the database. This replaces the older, dud code in 2.0.x which hardcoded those references in an .ini file.

I just tried an installation and didn't encounter any problems myself, but it's possible it's something to do with your unique configuration.

What's your $g_root_dir value (from your /global/config.php file)? Any unusual characters in it?

- Ben
Reply
#4
Hi Victory,

Never mind, I was able to reproduce this error in a different environment. I'll include the fix in tomorrow's build.

- Ben
Reply
#5
Sorry for all the posts! Never mind again: I included it in today's build.

Let me know if you continue to have problems (or if you spot anything else!)

- Ben
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)