The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Autoresponder does not work

I set up an email autoresponder. Email notifications to the admin are working but the autoresponder to an entered email address in the form not (form field has been set up as email field via the Form Tools admin interface). I entered the relevant data in the Swift Mail section.

I have also gone through the some of the suggestions as stated here:

Quote:In regards to the email, are you using the SwiftMailer module? You should try to run through some of the debugging reviewed in this thread:

Any idea how I can find a solution for my issue?

Many thanks,

Hi Philip,

Welcome to the forums. Smile

So just to clarify, the email tests that work for you: was that in the Swift Mailer module (the "test" tab), or were you referring to the tests on the Edit Form -> Emails tab -> Edit Email Template page?

If the Swift Mailer is sending the tests properly, most likely it's the content of your email templates that's causing the problem. To figure that out, you'll need to do a little debugging.

What I normally do is disable all the email templates then create a new one with as little content as possible. Only give it one recipient, only fill in one of the email content areas (HTML or text), then put through a test submission through your form. If that gets sent, then you know it's a problem with one of your email templates. Then enabled one email template at a time and slowly hone in on the problem that way.

I wish I had a better suggestion, but sadly there wasn't a good way to implement error checking of the email templates.

Let me know how it goes.

- Ben

Hello Ben,

Thank you for your suggestions. I don't know why but it's working now somehow. The email template was fine. I added "Use Authentification". Eventually it is related with that though the other emails were also sent without that.

Strange! But I'm very glad it's sorted out now. Smile

Post back if you have any other trouble.

- Ben

Forum Jump:

Users browsing this thread: 1 Guest(s)