FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Export Manager File Generation
#1
FT - core 2.1.0
Export Manager - 2.0.5

1. Created an Export Group with 2 Export Types

2. Assigned each export type to generate a file (different literal file name for each - php in this case).

3. All is well

4. Back in my selected form I can select the export types from the drop down and click Display to generate the files.

5. ISSUE: Whether I select the first or second option it is always the first export type file that is being generated. Tried changing their order and still - first export type file is being generated.

No problem as I created separate export groups and referenced the individual types/files that way (without grouping them) but would be great to see if this an issue you can recreate as the grouping is very useful.

Ted
Reply
#2
Hi Ted,

Quote:5. ISSUE: Whether I select the first or second option it is always the first export type file that is being generated. Tried changing their order and still - first export type file is being generated.

Uh-oh, this sounds like maybe a javascript bug. What browser & OS are you on? And in your browser, do you see any javascript errors? I'll take a look and see if I can reproduce it.

Oh - and are you on 2.1.0? If so, check you don't have the Mass Edit or Media Gallery modules installed or enabled. Neither are compatible with 2.1.0 and could cause JS errors that would interfere with the Export Manager code.

- Ben
Reply
#3
Ben,

Apologies for not supplying the required information. Will be a bit more dilligent in version numbers etc. I know it helps.

I am not using the Mass Edit or Media Gallery and have stuck to the 2.1.0 compatible modules. FT has been updated so all modules/core are up to date.

FT - 2.0.1
Export Manager - 2.0.5


I tried the above in :

IE 9
Chrome 13.0
FF 6.0

All on Windows 7 Pro

No JavaScript errors are appearing - and as mentioned the process works great if I have a single export type.

I then changed the export types from file generation - to open in new window to see if there was any difference.

This time the files are generated based on the file type file names. This works.

Changing back to generate file on server - the first file is again selected irrespective which one I choose.

Hope this is helping a bit?

Ted
Reply
#4
Absolutely! Sounds like it may be a problem with the module. I'll look at this today and get back to you.

Thanks, Ted! Smile

- Ben
Reply
#5
Yup, it's a bug. I'll look into it right now - I should have a fix ready later tonight.

Thanks for letting me know about this, Ted -

Ben
Reply
#6
Hi Ben,

Upgraded to 2.0.6 Export Manager. The multiple generated export types works.

Have attached some notes and screen shots that may be of interest:

http://www.tidalfire.com/downloads/export_info.pdf - description

http://www.tidalfire.com/downloads/export.pdf - screen shots

Hope these help.

Ted
Reply
#7
Hi Ted,

Thanks for the detailed error report - very helpful!

I'm going to look through the code now. I can't reproduce it myself, but my hunch is it's a permissions problem.

Here's the thing: by default all Export Types within the HTML/Printer-friendly Export Group generate files with the same filename: "submissions-{$M}.{$j}.html".

So, once the file has been generated, I'm wondering if subsequent attempts are simply throwing the (invalid!) error that you spotted.

Try this: on your server, take a look at the file permissions of the generated file. It's found in your Form Tools /upload folder. What is it set to? Some servers create files with something like 600 permissions, which forbids overwriting. Try deleting the file, then re-generate it through the Form Tools interface. Does that work?

Quote:NOTE ‐ to update I run the update from FT and copy over the files into the FT directory. I then get a message that says I am updated. I hope this is the correct way to apply an update otherwise please let me know and I can apply it properly.

Yup! That's the right way to upgrade - you did nothing wrong at all.

[EDIT: I just updated the Database Integrity module - that problem is unrelated, don't worry! The latest version of the module won't spot any (invalid) errors]

Thanks SO much! And I'm sorry for all the trouble.

- Ben
Reply
#8
One more word about this: I was able to reproduce the problem by explicitly setting the permissions on the file to prevent overwriting. Obviously the folder is writable or you'd have run into trouble.

Let me know if what I described above works for you: deleting the file and re-generating it through the Form Tools interface. If it does, I'll release an update to the module that explicitly sets the permission on all generated files to 777. This will prevent further permissions issues on files generated via the Export Manager.

(And I'll fix the dud link in the error message!)

- Ben
Reply
#9
Ben,

Thanks. Files are coming in at 644. I can generate files from the the multiple export types many times and it over writes them each time.

Deleted all files that were generated and tried again. Same result - cannot generate a file at all from the single export type option.

I took the multiple export type and just deleted one export type so that I now only have one option. As soon as I do this I get the error when trying to generate the file.

Please note: These errors are occuring on a live server and on a localhost configuration I may not have made that clear so I can reproduce on two set ups.

Re file names I have used the default variable file names that you mention get used in the export types and also hard coded the file names neither make any difference. The variable ones also inccur the wrath of permissions if part of a multiple export type within an export group.

Don't have much else just now but am happy to keep working at this and testing.

Ted


Ben,

OK tried it again. Mainly to test sanity. Mine.

Removed Export Manager (uninstalled and deleted) 2.0.6.

Installed 2.0.5 - all was back as before. No error message re permissions. Only issue was as mentioned in the start of this thread - multiple export types generating a file would always generate first file name.

I then upgraded to 2.0.6 and the multiple export types now save correctly with specific file name but the single export type generates the permissions error.

No permissions were changed during this entire process. I used the XML export just made it generate files for this exercise.

So will go back to 2.0.5 meantime and as long as I have single export types generating files its OK.

Strange stuff in Gotham city.

Ted
Reply
#10
Ahh...! I think I have it. When there's only a single export type, the information passed to the script won't contain the Export Type ID, since the export type dropdown won't show up in the page. Daft I didn't consider that.

Once 2.0.7 is available, I'll post back on this thread.

Sorry to make you question your sanity. The fault is on my end, not yours! Smile

- Ben
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)