The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ERROR process.php is not receiving any data

I'm trying to setup a basic html form, but I get this error every time I click my form's submit button:

process.php is not receiving any data. Note: this script cannot be loaded directly in your browser.
Make sure your form is sending via POST.

I have followed the instructions to the letter and have read the user documentation. I've even tried creating a form with one text input field (see below), but I still get this error.

<form action="" method="post">
<input type="hidden" name="form_tools_initialize_form" value="1" />
<input type="hidden" name="form_tools_form_id" value="1" />
<input type="text" name="str_your_email" />
<input type="submit" value="submit" />

Can anyone suggest a way to fix this?

EDIT: I'm using version 2.1 get the error regardless of what browser I use
Hi wchol,

Ah.... actually your form doesn't contain any data! Form submissions pass along name-value pairs for all fields in your form.

In your case, the two Form Tools fields (form_tools_initialize_form and form_tools_form_id) are ignored during the comparison. Secondly, the submit button doesn't have a name attribute, so that won't send along a value (this is fine), leaving only the final field: str_your_email. And if you don't enter a value for that, there will be nothing to add to the database.

Try filling in a value for the str_your_email field then re-submitting the form. You *may* need to add a value attribute as well, in some browsers.... but I very much doubt it.

- Ben
Hi Ben,

I've tried all of that already. I typed some text into the input field (str_your_email) in the browser and clicked 'submit' and I've tried assigning it a value in code, but it didn't work.

I'm going to try deleting the submitforms directory and reinstall Form Tools again.

Do any of the Form Tools files require special permissions on the server?
Hi wchol,

I really don't think you need to re-install just yet!

Try adding a value="whatever" attribute to that field, then double-checking the hidden fields that you added to the form to confirm they are what Form Tools is expecting.

If that doesn't work, add another field with both name & value attributes. If THAT doesn't work, then yeah, maybe there's something wrong with the installation.

And nope! Form Tools doesn't require any special permissions - at least, not on the forms - only on the theme cache directories (but it usually works without having to manually set it). Sounds like it's working fine for you.

Good luck! Let me know how it goes.

- Ben
Hi, Ben

I tried that but it still didn't work, so I reinstalled it in a directory called 'submissions'. Same problem.

Then it occurred to me that the form's 'POST' target url is "" (without the www), but my site redirects all non-www requests to the corresponding www address, like this: "". The form data was getting lost when the submission was redirected!

I added the www in the code and it's working perfectly now.

Thanks for your help!

Okay, so I've run into another problem now...

At step 5 I get a red box that just says 'Error', but provides no further information, when I click 'Next Step'. It does it regardless of whether I click 'Smart Fill' or 'Skip Step' first.
Chrome's Javascript Debugger shows the following when the Step 5 page loads:

Uncaught ReferenceError: sf_ns is not defined step5.php:644
Uncaught ReferenceError: sf_ns is not defined step5.php:592
Boy, you really are running into trouble! Smile

That error means it just can't find the Smart Fill JS code on that page. It's possible there was some weird load order in your browser when you came to the page and it didn't load the javascript file. Try simply refreshing the page, or going to the previous step and going to the next page again.

Failing that, clear your browser cache for the site and try again. I *doubt* it's a problem with the code...

Let me know!

- Ben
I wasn't able to replicate that javascript error again, but I tried using Internet Explorer instead of Chrome and this time the error at step 5 gives a bit more detail.

It says Error: No Transport

Ah ha... that was also because of the redirect!

I installed Form Tools using Softalicious and it configured it to have a root url that was without the www. I've added the www in config.php and it let me complete all of the steps.

Interesting! I'm glad you got it all resolved though. Smile

And interesting you're using Softaculous! Seems like that's getting more popular - I hear more about them all the time.

- Ben
-- Hello all, I too am having issues w/an old form which Ive now recently downloaded the 2017 version formtools to our site, instead having it relaying thru our old web developers site from MANY years ago. OnceĀ  install seemed to go well, I have 2 issues;
1) everytime I send a form from the Contact Pg on our site, it displays:

process.php is not receiving any data. Note: this script cannot be loaded directly in your browser.
Make sure your form is sending via POST.

The good news is that the post does shows-up on our Admin page on your formtools site. Though we do not get the message to the forwarding email.
2) the form layout was pretty basic before (name, email, phone number, message) and Ive attempted to leave it as it was before. The issue is that since Ive installed your formtools software, database and initialized our old form on our site, the form now displays the field titles (name, email, etc) on the right-side of the page, while the entry fields are on the left-side of page.... just exactly swapped (left-right) from what it should be & used to be.

I've looked thru this Forum and thru the Admin page and cannot seem to find answers or any controls which would resolve these 2 issues.

Can anyone assist me in what seems like a simple set of problems I have created.

thank you
I really like that you shared this amazing information on the ERROR process.php is not receiving any data. When i read the custom essay online I found the best ideas to get more and more updates to resolve such errors.

Forum Jump:

Users browsing this thread: 1 Guest(s)