FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Reply-to set to 'none' not working
#1
Hi Ben,

'Reply-to', set to 'none' in the 'Recipient(s)' section of the 'Edit Email Template' doesn't seem to work. The rest seem to work well, but when you set it to 'none', it doesn't seem to hold that setting in place when you click on the 'Update Email Template' button. Not sure if I'm doing something wrong.

Regards,
Tony
Reply
#2
Hmm... that sounds like a bug. I'll get back to you on this.

Oh - what Beta version are you running? (it'll be in the top right of the screen)
Reply
#3
I'm using the following version: v2.0.0-beta-20090131.
Reply
#4
Well spotted! I'll release a new version the code later today with a few other minor bug fixes; this will be included in the build.

- Ben
Reply
#5
Hi Ben,

I tested the 'reply-to', set to 'none' in the 'Recipient(s)' section. As it now sets this to 'none', when the user receives the email, you are still able to reply to the custom email address that was initially set in the 'From' section. Is it suppose to do this?

Regards,
Tony
Reply
#6
Hi Antonitus,

Are you using the Swift Mailer module? I was able to reproduce this problem when that module was enabled; but the default emailing option seems to work okay. I'll fix the module, but in the meantime I just wanted to confirm that this was the problem for you too.

- Ben
Reply
#7
Hi Ben,

No, I'm using the linux sendmail default mailer, not Swift. The system retains the 'none' option, but when the email is sent to the user, they are still able to hit reply to the email that is in the custom 'From' field. Not sure if this is ok or maybe I misunderstand it.

Regards,
Tony
Reply
#8
Ah, I see! Actually that's pretty much just the way most email clients work. The Reply-To header really just gives you an option to override the default From field so that when the user clicks "Reply", it goes there instead.

Most people patch this by adding some text to the email saying "Please don't reply to this email", or creating a dud "no-reply@whatever.com" email address where all the submissions go straight to the trash. Not perfect, I know.
Reply
#9
Ok, now I understand. But I'm still a little confused as to what the real purpose of the 'reply-to' set to 'none' option is if the email client cannot handle this or does it work well with browser webmails?

It's no big deal though. This system delivers a whole lot more and I'm extremely happy with it.

Once I find a client who will be using this as a paid service then I will donate again as it's worth it's weight in gold or maybe I can offer you free web hosting for a year.

Regards,
Tony
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)