FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Drop Down Fields Not Collecting Data
#1
Form Tools 2.1.2

After installing & testing I go to edit the forms.
On the Edit Forms - Fields interface, if I set the fields to "Drop Down" (which they are) they no longer collect data.
If I leave everything at "textbox" they work.
Is this because when I created them and did the SmartFill it decided they were "textbox" instead of "dropdown"?

ALSO: Say I created the form using a page /registration_test(dot)php but the actual page that this is going to be used on is /registration(dot)php... do I go back into my Edit Form - Main and CHANGE the "form url" to what is actually the form or the original?

THANKS SO MUCH!
Reply
#2
Hi Braven,

Sorry for the wait. Did anything change at all? Funny it would just stop working. (Did you do an upgrade?)

By far the most common cause for this is that the value="" attributes of your dropdown's <option> tags don't match the values in the Option List. They have to be identical - no extra spaces, same case - everything - in order for it to work properly. Could you check that over (if you haven't already)?

But don't worry about how the field was created or configured - none of it boxes you in, so you can always reconfigure it later. It certainly wouldn't cause problems.

Quote:ALSO: Say I created the form using a page /registration_test(dot)php but the actual page that this is going to be used on is /registration(dot)php... do I go back into my Edit Form - Main and CHANGE the "form url" to what is actually the form or the original?

It actually doesn't matter! When I originally wrote the script, I figured that sometimes you'd need multiple forms at different locations submitting to the same Form Tools form. Because of that, the code doesn't check that the URL on file matches the actual form URL.

- Ben
Reply
#3
O goodness! to apologize for the wait when you offer this fantastic tool for free and help all of us struggling to fine-tune our individual uses of it? Silly man.

No, nothing had changed. I did update to 2.1.2 but created all new forms when I did.
Perhaps it is because I am utilizing the code that saves the entered fields in case the recaptcha words don't match.

At any rate, it is fine, I just left all my forms to "textbox" for all the "dropdowns" fields and it seems to be working fine, we are no longer getting forms with missing data fields.

Thanks as always!

- Billie
Reply
#4
haha, I always feel bad when I can't keep up with the forum! Can't help but apologize...

Still, if you ever feel like investigating this further, just post back! Smile

- Ben
Reply
#5
(Oct 7th, 2011, 9:52 AM)Ben Wrote: haha, I always feel bad when I can't keep up with the forum! Can't help but apologize...

Still, if you ever feel like investigating this further, just post back! Smile

- Ben

found this old thread because I implemented Form Tools on an external form that we had on our site, and oddly, one out of four drop down menus doesn't pass data, although the other three do. i've checked the Field Names carefully, and they match what Form Tools has.

for the one that doesn't pass data, if i change the Field Type to "Textbox" it works fine. Changing it to "Dropbox" breaks it.

i'm using version 2.1.5
Reply
#6
Can you post the HTML you are using for each of the four drop boxes, please?
Also - and I am assuming here that you are using the API - please post any validation rules you're using for each of these four fields.
Not a FT employee, just a FT user lending a hand. If I've been helpful, please rate.

[Image: giraffe_long_85.gif]
Reply
#7
the one that is NOT working is the first field on the form:
Code:
<select class="other" name="q13_Title" id="q13" >
  <option></option>
    <option>Mr.</option>
    <option>Ms.</option>
    <option>Dr.</option>
    <option>Mr. and Mrs.</option>
    <option>Dr. and Mrs.</option>
   </select>

the following three work fine:
Code:
<select class="other" name="q5_State" id="q5")" >
  <option></option>
    <option>AL</option>
    <option>AK</option>
    <option>AR</option>
--etc--
    <option>WI</option>
    <option>WY</option>
   </select>

<select class="other" name="q6_Country" id="q6" >
  <option></option>
    <option>Abkhazia</option>
    <option>Afghanistan</option>
    <option>Aland</option>
--etc--
    <option>Yemen</option>
    <option>Zambia</option>
    <option>Zimbabwe</option>
   </select>

   <select class="other" name="q16_Howdidyouhearaboutus" id="q16" >
  <option></option>
    <option>Friends/Relatives</option>
    <option>Search Engine</option>
    <option>Surfing the Web</option>
    <option>Newspaper Ad</option>
    <option>Flyer</option>
    <option>Other</option>
   </select>

validation rules:
title field (that doesn't work): none
state: required
country: required
howdidyouhearaboutus: none

not exactly sure what you mean about the API - i'm just using the Form Tools control panel to edit the fields...

thanks,
janaki
Reply
#8
I don't understand why you have the extra )" in the state field. Was that a typo? It shouldn't be causing this problem, but.. still worth fixing.

I guess I don't fully understand how you are implementing FormTools to work for you. Can you send me a PVT message with a link to the live form? Maybe I can get a better understanding that way...
Not a FT employee, just a FT user lending a hand. If I've been helpful, please rate.

[Image: giraffe_long_85.gif]
Reply
#9
I Have Version 2.2.6 , Need Your Assistance , Help Please

email id: vignesh@tabletzone.in
Reply
#10
If it is not collecting the data then you need try again.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)