FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Install good - can't upgrade
#1
Hello everyone.

I have been having problems upgrading to the latest version (2.0.0-beta-20090627).

I had been running 2.0 (2.0.0-beta-20090312), then today upgraded to 2.0.0-beta-20090614 which works fine.

I did the Upgrade as per instructions, FTP'd the files over, and then get this error message:

Parse error: syntax error, unexpected T_ELSE in /home/mysite/public_html/f_tools/global/code/submissions.php on line 1238

I am a coding nerd, and haven't a clue what this means. I looked at the .php file, but there isn't anything that looks hokey. I compared the 20090614 version with the 20090627 version, and didn't see anything that was obviously bad.

So, I loaded 20090614 back on, and it's okay again.

I thought that perhaps there were some corrupted files during download, so redownloaded files from the "Upgrade" area again. Same problem.

I tried another route: getting the download from the "Custom Build" link. No joy there either, I get the same error message.

And if I try to swap out the bad "submissions.php" with the older version, then I just get a different file error (i.e., Parse error: syntax error, unexpected '{' in /home/cantuand/public_html/f_tools/global/code/upgrade.php on line 189"). Besides, swapping out and going back to the older file defeats the purpose!

So, I am wondering if anyone else has had this problem? And if so, any ideas on how to fix it? Is it me, or is there a little bugger in the file??

Any help would be greatly appreciated. Thanks!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)