FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
July 8, 2009 - Swift Mailer not working
#1
Well PHP mail() works but the Swift Mailer module throws some lines in the Apache error logs and the email never shows up. Something must have happened with one of the more recent updates.

Core Version 2.0.0-beta-20090627
API Version 1.0.0-beta-20090614
Swift Mailer 1.0.0-beta-20090613

[Wed Jul 08 20:08:52 2009] [error] [client x.x.x.x] File does not exist: /home/yyyy/www/formtools/global/scripts/builder.js, referer: http://zzzz.org/formtools/modules/swift_.../index.php
[Wed Jul 08 20:08:52 2009] [error] [client x.x.x.x] File does not exist: /home/yyyy/www/formtools/global/scripts/dragdrop.js, referer: http://zzzz.org/formtools/modules/swift_.../index.php
[Wed Jul 08 20:08:52 2009] [error] [client x.x.x.x] File does not exist: /home/yyyy/www/formtools/global/scripts/controls.js, referer: http://zzzz.org/formtools/modules/swift_.../index.php
[Wed Jul 08 20:08:52 2009] [error] [client x.x.x.x] File does not exist: /home/yyyy/www/formtools/global/scripts/slider.js, referer: http://zzzz.org/formtools/modules/swift_.../index.php
[Wed Jul 08 20:08:52 2009] [error] [client x.x.x.x] File does not exist: /home/yyyy/www/formtools/global/scripts/sound.js, referer: http://zzzz.org/formtools/modules/swift_.../index.php

Any thoughts? Any other data I can provide?

Thanks for FT!
Chuck
Reply
#2
Hi everyone,

I am also having the same issue here, except my User emails have yet to come through. I thought it was because I didn't have the SMTP thingy installed, so installed it... I thought. The tests come through, but no actual user submissions to the submitter - I do get the Admin emails notifying me that a submission has been made.

None of these .JS files are anywhere that I've been able to find... in the newest version or in any of the older versions. Where are they coming from, and how can it be expected to work if there are files called for that don't exist? I'm stumped. *scratches head*

In addition to the weird .JS files in my error log, I can tell the Mailer isn't installed because the "Undeliverable Email Recipient" field isn't showing up in the Recipients tab.

I've been having issues with FT since updating to the 20090627. I'm wondering if there is a problem with this version causing these problems? I've uploaded/downloaded and reloaded this version several times now and have become a bit frustrated with myself that I can't get it to function properly. Where can I get an older version (i.e., something around May 2009) of FormTools?

Thanks - appreciate any help. :-)

---
p.s. I really like the idea of FT, and it has worked for me in the past (older version), so am hoping to be able to get this one working too. :-)
Reply
#3
Hey Chuck,

Those error messages are just related to Prototype - the JS library included in Form Tools. It's not related to the emails not being sent.

Hmm. Do you recall which version you were running when everything was working okay?

I'm going to do some tests on my end, but last time I checked it was all working properly.

- Ben
Reply
#4
I'm wondering if perhaps it's something to do with the modifications that were made - it's possible they're now out of synch with the core code or something. I've been doing some testing and everything seems to be a working properly.

Just Me - did you make any customizations (e.g. Chuck's changes)?

Would either of you mind trying this:
1. back up your version of the Swift Mailer module (just copy it to your desktop or something)
2. completely uninstall it from your (note: jot down your SMTP settings!)
3. re-download the module (http://modules.formtools.org/swift_mailer/download.php) and put through a submission through one of your forms that's been configured with one or more email templates. Does it go through?

Ahhh... wait, CAN you test the Swift Mailer without SSL? Or is the SSL only needed for connection to Gmail? If so, just temporarily disable the SSL requirement for Gmail while testing.

Sorry for the 20 questions. Just trying to get to the bottom of this!

- Ben
Reply
#5
Hi, thanks for the response... have been yankin' my hair out. ;-)

No, I've made NO customizations. I am using "Direct" submit, not API (don't know how to use that... I'm a coding 'dummy'!). I didn't even tweak on the email content - just used the standard there too.

My forms are .html (both the submission form and the thank you form).

I have tried totally uninstalling and then reinstalling Swift Mailer from the direct module download. I've tried two older versions (20090312, 200-0614) as well as the new version (20092709).

I get the Test message to come through, but there is no "Undeliverable" field, and I get no User emails. Now, when a User tries to submit, they don't even get the "Thank you" page. I've also gotten errors right after submitting the form (and don't get the thank you page), again, from memory, something about 'Undeliverable inquiry'??

In addition to the error logs wanting the JS files, I've also gotten this (from memory as I've totally unistalled FormTools until I find the problem): /global/code/style.css. This one surprises me too, because I didn't know there is a css in the global?? I've not been able to find it in any of the files/folders. Stumped!!

I'm not sure what the SSL is, but I don't think I have it or have had it activated (if that's what you do), so mine is just 'standard' (I guess??).

The last version I had that was working okay was 20090518, but no longer have that on my computer as I'd had a hard drive crash and lost data since then. Speaking of older versions, is there a place I can download them? I think I'd like to have the 20090518 version... at least that one worked.

I don't mind the questions at all, and I am MORE than happy & willing to test and try anything and everything you might suggest, and give you feedback on each trial. I'm just wondering if my new downloads for the updated version are getting corrupted during download? I've tried them several times, and the last two times I uploaded 20090614 because of problems with 20090627. Might you have a link to the 20090518?? That was also my birthday (05-18), and since I didn't have any problems when running that one plus the date, I though maybe I'd go back to that version.

Anyway, I'll keep trying any of your suggestions. Thank you so much! :-)
Reply
#6
Heya,

Eeck. Sounds like a real headache...

Quote:Now, when a User tries to submit, they don't even get the "Thank you" page

I think this is our biggest clue. This suggests it's a straightforward PHP error - if there's a major problem in the code, like a syntax error or something, it'll just die at that juncture. I'm going to do a totally fresh installation of the latest version and see if it still breaks. Now I'm wondering if the files got out of whack on the server or something...

I just enabled 20090318 for download again (there wasn't a 20090518, so I think this is the one you had in mind?). You can download it here: http://modules.formtools.org/swift_mailer/download.php

I'm a little worried that this old version simply won't work any more, though. The Form Tools Core was updated to add a little new functionality for the Swift Mailer module (a later version), but it's worth trying...

I'm just revising the module to allow for the SSL / TLS and batch emails as per Chuck's post. Should have it ready later today. I'm hoping that I can locate & resolve the problem you're encountering as well.

Keep you posted.

- Ben
Reply
#7
(Jul 11th, 2009, 10:42 AM)Ben Wrote: Hmm. Do you recall which version you were running when everything was working okay?

To the best of my knowledge it was working up to one of the last 2 upgrades. I'm running all the default files. I'm not using Gmail or secure connections at the moment so none of the modified files are in use.

Thanks for looking at it Ben!
Reply
#8
btw, don't worry about that CSS file either - there IS a CSS file in the /global folder that's shared amongst all themes. Just FYI!
Reply
#9
Hey guys - sorry, one more question (and apologies if you've already told me this somewhere down the line!): are you running PHP 4 or 5?

Also, did either of you change your email templates at any point? Just wondering if that may be the cause... I did a totally fresh installation and still no luck - works OK on my end (PHP 5).

- Ben
Reply
#10
(Jul 11th, 2009, 12:51 PM)Ben Wrote: are you running PHP 4 or 5?

PHP 5 here too.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)