FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
July 8, 2009 - Swift Mailer not working
#11
Thanks for the info.

I got a new version ready for testing. I've tested it with two different SMTP servers (local domain + Gmail) and it all seems fine - but I'd like you, Chuck, to try it first. Specifically, I've added a few new settings including the anti-flooding options mentioned in your last thread.

The new options are:
- anti-flooding added + choice of setting total emails sent and wait-time between batches
- email charset (default: UTF-8 like now)
- choice of encryption: SSL & TLS
- server connection timeout setting (default: 15 seconds)

However, I don't think this will fix the problem you guys have been encountering. I don't suppose it would be possible for either of you to give me temporary access to your servers to debug it directly? I've looked through the changes that have been made over the last few releases and there's nothing that seems the likely culprit.

No worries if not.

Send me an email at ben.keen@gmail.com to get the new version. I won't push it live until we get to the bottom of the problems you're encountering.

- Ben
Reply
#12
(Jul 11th, 2009, 12:51 PM)Ben Wrote: Hey guys - sorry, one more question (and apologies if you've already told me this somewhere down the line!): are you running PHP 4 or 5?

Also, did either of you change your email templates at any point? Just wondering if that may be the cause... I did a totally fresh installation and still no luck - works OK on my end (PHP 5).

- Ben


Hi.

I'm running php5.

And I did *initally* change my template design, but used the "Reference" fields (Admin HTML with all fields, and User/Client omitting empty fields - not the Smarty, and not the last options, but the top ones). But in trying to troubleshoot, I went back to using standard templates to see if that was the issue (I really am trying to help myself first before asking!), but still had problems.

Here is info on my server:
==========================
cPanel Version 11.24.4-RELEASE
cPanel Build 36167
Theme x3
Apache version 2.2.11 (Unix)
PHP version 5.2.9
MySQL version 5.0.81-community
Architecture i686
Operating system Linux
Shared Ip Address 207.210.64.50
Path to sendmail /usr/sbin/sendmail
Path to PERL /usr/bin/perl
Kernel version 2.6.18-92.1.1.el5
.028stab057.2PAE
cPanel Pro 1.0 (RC1)
=====================

Regarding the versions: To the best of my knowledge, my last working version I ran (uploaded to my server via FTP) was from a download (from your download link on your site) from March 12th (cut & paste from the "global/library.php file": $g_current_version = "2.0.0-beta-20090312";), then in April I did an upgrade (via the "Upgrade" link from within my Form Tools Admin [if I remember correctly] via directions on your site - cut & paste from the "global/library.php file": $g_current_version = "2.0.0-beta-20090428";), and in May I did another download and upgrade (cut & paste from the "global/library.php file": $g_current_version = "2.0.0-beta-20090518";).

This last version (the May 18th Upgrade) I believe is what I'd been running until just recently (just a few days ago), when I tried to upgrade to the 6-27-09 version. That crashed everything, and I've had problems since, and have had to remove Form Tools entirely because I just can't get it to work. Thank you for the older version link though... I will try that.

And I think that I was not using the Swift Mailer (again, if I recall, I don't remember tweaking on an added Module), so that shouldn't factor in I don't think. I asked about it here because I'd tried to get it to work only because I wasn't successful with the standard way (php mail) of getting the emails to the User. So, I figured with the new version (6-27-09), perhaps using Swift Mailer would work - not. ;-)

I would be happy to show you a .php file that tells you what I'm running - I don't recall how to get it though, so if it is something you care to see if you would, kindly let me know how to get it? ;-)

Thank you for your input and assistance on this - it is very much appreciated. I do want to get it working again, as it is the best thing I found for using my Forms in the way I need to. :-)

p.s. I'm not using a secured server - is that what SSL means? (sorry for my inexperience)
(Jul 11th, 2009, 12:31 PM)Ben Wrote: Heya,

Eeck. Sounds like a real headache...

Quote:Now, when a User tries to submit, they don't even get the "Thank you" page

I think this is our biggest clue. This suggests it's a straightforward PHP error - if there's a major problem in the code, like a syntax error or something, it'll just die at that juncture. I'm going to do a totally fresh installation of the latest version and see if it still breaks. Now I'm wondering if the files got out of whack on the server or something...

I just enabled 20090318 for download again (there wasn't a 20090518, so I think this is the one you had in mind?). You can download it here: http://modules.formtools.org/swift_mailer/download.php

I'm a little worried that this old version simply won't work any more, though. The Form Tools Core was updated to add a little new functionality for the Swift Mailer module (a later version), but it's worth trying...

I'm just revising the module to allow for the SSL / TLS and batch emails as per Chuck's post. Should have it ready later today. I'm hoping that I can locate & resolve the problem you're encountering as well.

Keep you posted.

- Ben

Hi. Sorry, no, the versions I was referring to was the Form Tools version, not the Swift Mailer version. My apologies for not making that clear. Is there someplace to download older version of Form Tools (core files) please?
Reply
#13
Hey just me -

I'm hoping that all these problems being encountered have the same root cause. xoxo just sent me her server info so I'll debug it there and see what I can find. Keep you posted...!

- Ben
Reply
#14
Phew! Turns out that the issue with xoxo's particular installation was just a configuration problem. After speaking to their (amazingly good!) hosting provider, we got it sorted.

I think it's okay to release this new version now. Will do very shortly...

-Ben
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)