FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Installation Problem
#1
Hi Ben,

After installing, when I try to access http://domain/admin, I get the apache page with this URL

http://domain/?message=notify_no_account_id_in_sessions

Any idea why?
Reply
#2
Hey Frosty,

You'll see that URL anytime your session expires and you try to visit a Form Tools page; it just boots you out. If you ALWAYS see that URL - i.e. you can't even log in - that means that there's probably a problem storing information in sessions.

One option you might want to try is switching to database sessions. To do this, just edit your /global/config.php file and add the following line:

PHP Code:
$g_session_type "database"

Then try logging in again.

PHP and database sessions both do exactly the same thing: store information about your user session as you go through Form Tools. Database sessions just store the information in a separate MySQL table; PHP uses standard PHP sessions.

[A quick shout out to Tara at ActiveState for writing this Form Tools feature! Thanks, Tara!]

Let me know if this doesn't help!

- Ben

[EDIT: You'll need to be running 2.0.0-beta-20090223 or later for this, btw].
Reply
#3
Hi Ben,
Installed version (2.0.0-beta-20090428) and encountering this exact issue.

Added the following line: $g_session_type = "database";
to /global/config.php file.

Then tried logging in again and got the same error:
"No user account ID was found in sessions."

Any ideas? Thanks for your time!

(Mar 2nd, 2009, 10:19 AM)Ben Wrote: Hey Frosty,

You'll see that URL anytime your session expires and you try to visit a Form Tools page; it just boots you out. If you ALWAYS see that URL - i.e. you can't even log in - that means that there's probably a problem storing information in sessions.

One option you might want to try is switching to database sessions. To do this, just edit your /global/config.php file and add the following line:

PHP Code:
$g_session_type "database"

Then try logging in again.

PHP and database sessions both do exactly the same thing: store information about your user session as you go through Form Tools. Database sessions just store the information in a separate MySQL table; PHP uses standard PHP sessions.

[A quick shout out to Tara at ActiveState for writing this Form Tools feature! Thanks, Tara!]

Let me know if this doesn't help!

- Ben

[EDIT: You'll need to be running 2.0.0-beta-20090223 or later for this, btw].
Reply
#4
Hey mvpacific,

It sounds like the $g_root_url value in your /global/config.php file is incorrect. It should link to the folder that contains your Form Tools installation. By the sounds of it, this is the admin folder, correct?

Try tacking on /admin to the end of the config value.

- Ben
Reply
#5
Hi Ben,

Thanks for your promt reply. /admin was added to the config value of the $g_root_url value in /global/config.php file and got this error:

The "index.tpl" template could not be located at the following locations: .../admin/themes/default/index.tpl.

I removed /admin from the value, and login screen loads.
When logging in I get error:
"No user account ID was found in sessions. Please log in again".

The url at top directs to www..../?message=notify_no_account_id_in_sessions
Reply
#6
Are you on a Windows server?

Could you check the permissions on that folder - it sounds like maybe the contents of the /themes folder aren't readable. Or they may not even exist... so check that the files have, in fact, been uploaded to that location.

- Ben
Reply
#7
I have a similar error, and that's because links on FT pages go to seosumo.com, which we preferred for our wordpress website, but FT pages only load when www. is used.

How do I say FT to consider seosumo.com and http://www.seosumo.com the same?
Reply
#8
Hi Ben,
We are running UNIX server.

Permissions on /themes folder is readable (permissions set to 777).

All directories+files within /themes directory exists:
- themes/default (permissions set to 777).
- themes/deepblue (permissions set to 777).
- themes/classicgrey (permissions set to 777).
Reply
#9
Hi Ben,

I downloaded the latest package (2.0.0-beta-20090627).
Still receiving the following error when logging into the admin after setup is complete. "No user account ID was found in sessions. Please log in again below." Any ideas?

Thanks for your time.
Reply
#10
I was experiencing a similar problem with an existing installation of Form Tools which just suddenly quit working. When I tried to log in the login page would be reloaded and "message=notify_no_account_id_in_sessions" would be appended to the URL

Adding
PHP Code:
$g_session_type "database"

to my config.php file worked.


(Mar 2nd, 2009, 10:19 AM)Ben Wrote: Hey Frosty,

You'll see that URL anytime your session expires and you try to visit a Form Tools page; it just boots you out. If you ALWAYS see that URL - i.e. you can't even log in - that means that there's probably a problem storing information in sessions.

One option you might want to try is switching to database sessions. To do this, just edit your /global/config.php file and add the following line:

PHP Code:
$g_session_type "database"

Then try logging in again.

PHP and database sessions both do exactly the same thing: store information about your user session as you go through Form Tools. Database sessions just store the information in a separate MySQL table; PHP uses standard PHP sessions.

[A quick shout out to Tara at ActiveState for writing this Form Tools feature! Thanks, Tara!]

Let me know if this doesn't help!

- Ben

[EDIT: You'll need to be running 2.0.0-beta-20090223 or later for this, btw].

Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)