FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
redirect submission after form have been turned off
#1
Client has a online seating auction system built with FT API. The only issue is when the client turns the form off to stop the bidding users can still submit but are then redirected to an error page. Does anyone now a workaround to redirect/or change the error page #303 so the clint gets an official Bidding Closed. Thanks in Advance!
Reply
#2
Interesting!

Taking the form offline through that setting has always been a rather odd feature, truth be told. I intended it purely for programmatical purposes: to prevent any new form submission - even faked POST requests - from being added to the database. I hadn't thought that people would use it to take their forms offline since it seemed better for them to actually remove the form itself (no-one wants to fill in a form just to find out it's offline!).

But this is a reasonable requirement & I've gotten this request before. I'm releasing a new build today or tomorrow - I'll include an option for you to include a hidden field in your form: form_tools_inactive_form_redirect_url. When that is set and the form is inactive, the user will be redirected to that URL.

This will affect both API and POST forms.

All the best -

Ben
Reply
#3
Hey bwaye,

I just released the update. It works exactly as described in my previous post. Let me know if you have any trouble with it! Smile

- Ben
Reply
#4
(Aug 15th, 2009, 2:10 PM)Ben Wrote: Hey bwaye,

I just released the update. It works exactly as described in my previous post. Let me know if you have any trouble with it! Smile

- Ben

awesome!
Ben,

First thanks for addressing this issue. I have a few questions. I set up a new form using the API and added a hidden filed to the form: <input type="hidden" name="redirect" id="http://www.site.com/" />.

When I took the form offline i am still being redirected to the error page. I sure I must be missing something.

Thanks in Advance.
Reply
#5
Hi Bwaye,

Ah - try changing your hidden field to this:

Code:
<input type="hidden" name="form_tools_inactive_form_redirect_url" value="http://www.site.com/" />

Note the different name attribute and that I renamed your id to value.

- Ben
Reply
#6
(Aug 21st, 2009, 6:00 PM)Ben Wrote: Hi Bwaye,

Ah - try changing your hidden field to this:

Code:
<input type="hidden" name="form_tools_inactive_form_redirect_url" value="http://www.site.com/" />

Note the different name attribute and that I renamed your id to value.

- Ben

THATS IT! - nice job
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)