FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
install Blank page, ubuntu server
#1
Hi everyone,

VM - ubuntu server 16.04.2
PHP7
Mysql 5+

Folder .../formtools/theme/default/cache = chmod 777

all formstools under www-data:www-data

Still getting blank page.

Maybe there is a bug? Or did I forget something?
If I don't put cache in 777, I see the page asking for it, once I do it I got a total blank page.

ANy idea?

Thx
Reply
#2
(May 5th, 2017, 2:49 AM)yozeur Wrote: Hi everyone,

VM - ubuntu server 16.04.2
PHP7
Mysql 5+

Folder .../formtools/theme/default/cache = chmod 777

all formstools under www-data:www-data

Still getting blank page.

Maybe there is a bug? Or did I forget something?
If I don't put cache in 777, I see the page asking for it, once I do it I got a total blank page.

ANy idea?

Thx
Reply
#3
I have the exact same issue, with the same OS specs... Any help on this?

Frank
Reply
#4
I think I can shed some dark on this. A few posts down, we are informed that Formtools isn't compatible with php7 and this is most likely because all the old mysql_* functions which WERE deprecated in php5 are now removed. This is tough titties for all ubuntu users because as far as I can tell, without going through a lot of messing around with PPAs and installing obsoleted versions on your system, you cannot get php5 on ubuntu.
You could try setting up some shim functions which map the old mysql-* stuff to mysqli_* calls but this is a bit beyond my chops as a code monkey and the one example I found on Stack Overflow (search "undefined function mysql_connect") is incomplete.
It is beyond me why the last five most useful looking PHP form builder tools I've looked at, all have this problem and require obsolete 5 year old software in order to work. Surely it is well past time to start using mysqli?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)