FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
post validation field problems!!
#1
Hi,

My API integrated forms return all the fields with blank after validating errors, even the correctly entered ones. Here is on of the forms to verify the problem I am facing where one can enter a wrong info and see how it happens:

http://www.imanage4you.com/contact_alok_singh_2.php

This is also the problem with the home page form too!!

To recall, this problem started when I stringed namespaces for the two forms to separate the receipt of submission into the correct forms in Form Tools.

My website is live where people come to seek my service and if they encounter this problem it would not be good for me!!

Look forward to your help.

Many thanks

Reply
#2
Hi Alok,

I just tested out your form and the fields are returned after validation. Do you mean that fields are returned empty when submitted into Form Tools?

Cheers,

Joe
Reply
#3
Hello Joe,

I received the form submission info and I guessed that someone is testing my form from Form Tools.

Thanks to you Joe!

It is a bit queer...let me see if I can explain...There are two things happening....

1 - When I open the form in the browser (first time) or go through the home page and deliberately enter some wrong info or leave some fields empty and click submit, the page echoes with the error notifications but the correctly entered fields also disappear (the whole form is returned empty).

2 - On the other hand, in my first visit to the site when I correctly enter all the fields and submit then while still on the site (re-visiting the page while still on imanage4you) re-enter wrongly in this form or the one in the home page, the errors echo but the this time correctly entered fields return - they do not disappear!

Could I suggest you to kindly check it this way.....
1 - go to the home page/contact page and on either of them, enter one field and others with error or empty and click submit? This should return all the fields as blank!
2 - Enter the forms correctly on the first instance and then re-visit the page and enter wrongly, the correctly entered fields should remain!

Many thanks
Alok

(Jul 2nd, 2013, 7:42 PM)Joe Wrote: Hi Alok,

I just tested out your form and the fields are returned after validation. Do you mean that fields are returned empty when submitted into Form Tools?

Cheers,

Joe

Reply
#4
Hi Alok,

The issue isn't really a problem with Form Tools. You just need to save your data to a session and when the validation is returned, the data will display in the fields again.

Here's a link to the PHP Manual on sessions: http://php.net/manual/en/session.examples.php

Here's specifically how to do it for a form: http://stackoverflow.com/questions/37914...n-variable

Cheers,

Joe
Reply
#5
Smile 
Hello Joe,

Thank you for getting back to me. Your advice greatly helped me to realise that I had not amended the form name in the sessions saving part when I created namespace. Now both the forms are working well and repopulating the fields.

thanks a lot.

Alok
(Jul 5th, 2013, 11:03 AM)Joe Wrote: Hi Alok,

The issue isn't really a problem with Form Tools. You just need to save your data to a session and when the validation is returned, the data will display in the fields again.

Here's a link to the PHP Manual on sessions: http://php.net/manual/en/session.examples.php

Here's specifically how to do it for a form: http://stackoverflow.com/questions/37914...n-variable

Cheers,

Joe

Reply
#6
My pleasure. Happy to help.

Cheers,

Joe
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)