FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
After upload, URL returns error: [an error occurred while processing this directive]
#1
Question 
Hello,
I was very excited to try Form Tools, I think it may be exactly what I need, if I can only get in and take a closer look.

But after uploading the formtools folder, and resetting the permissions to 777 (recursively), I can not get to the install page.

When I point to http://mysite.com/formtools/
(also tried http://mysite.com/formtools/index.php)
I get a white page with this string:
[an error occurred while processing this directive]

Versions I am using (broken down based on your requirements page):
php 5.2 (not 'single', not FastCGI)
MYSQL: 5.5.32
PHP Sessions: I know what this is (after a Google search), but I don't see any docs (including a search on my host providers site, HostMonster) indicating that this can be turned on or off. I have to assume that its there for any script which calls it.
PHP mail(): ditto, as I compose this, I am goggling thru documentation. this is supposed to be set in php.ini, I suspect my issues may be there.

The reason I think it might be the php.ini, is because there was not one there when I started this exercise (although i have several other php scripts working on this site - for whatever that's worth).

After reading several articles on the subject on HostMonster help, I generated a php.ini, as they suggested, by re-choosing my current php version (php 5.2 - not 'single', not FastCGI), and saving. This created a brand spanking new php.ini on public_html - I made no changes to that file.

I did try to copy the file into http://mysite.com, as well as http://mysite.com/formtools, trying different variations of the file placement.

...but then again, it might have nothing to do with php.ini, I have no idea.

Help me Form Tools Forum, your my only hope!
Reply
#2
I have Resolved this issue.
I with I could tell you exactly what it was, I only know this:

- PHP was fine on my site before.
- Multiple uploads of Form Tools, and setting permissions as suggested, yielded no movement forward.

But many hours of research had convinced me that there were only 3 factors involved:
php.ini, .htaccess, php Configuration (default, single php, fastCGI)

I tried many modifications to these (from suggestions found on this forum and others), in any number of combinations. I became fluent enough in the concepts and lingo that I felt I could communicate the issues to a tech-support rep at HostMonster.

With more then a little effort and patience, he came up with the right settings, for the right files, in the right locations, with the right implementation of php.

its up and running, AND ITS EVEN BETTER FOR MY NEEDS THEN I HAD ANTICIPATED!!!

Now onward thru the forum to figure out table names for forms.
Reply
#3
Thanks for sharing your solution and feedback!

Cheers,

Joe
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)