The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Call to undefined function ft_api_init_form_page()
I just moved a site to a new hosting server. Replicated everything exactly and all seemed well till my client reports their form pages are not loading. We see just a blank white page. Through trial and error, I find the page(s) load properly except when the following FormTools related code is in the head section. So, I'm guessing there's something in this code which isn't quite right in this new server environment.

$fields = ft_api_init_form_page(3);
$params = array(
  "submit_button" => "Submit",
  "next_page" => "thank-you.php",
  "form_data" => $_POST,
  "finalize" => true

The browser just displays a blank white page.

I tried changing "require_once" to "include" and the resulting page load provided the following error message.

Quote:Fatal error: Uncaught Error: Call to undefined function ft_api_init_form_page() in /home/myuser/public_html/survey/CWS/index.php:21 Stack trace: #0 {main} thrown in /home/myuser/public_html/survey/CWS/index.php on line 21

I tried a few different document root paths in hopes it was just an error in the path. After trying many variations on the document path in the require_once statement, I've been unable to get past this error.

What am I missing? This page was working perfectly in the previous server environment and I can't find a way past this "undefined function" error.

I was able to get the forms working properly by simply removing the block of code shown in the original post.
It’s a discussion site where people share their opinion and get others that is usually used in online business . forum is used as a indicator and a way of exchange information in a rush essay to give more satisfaction to the users.

Forum Jump:

Users browsing this thread: 1 Guest(s)