FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
german characters
#1
Hello, I'm new here and my question is probably only for gerrman language important. I made a form in Form Tools and my problem is, that geman characters such as <öäü ÖÄÜ ß> written in text fields are not submitted to the database and not submitted by e-mail too. More ever, the string is cut before such characters.
I'm using the 2.2.5 version and my provider is STRATO. The database has a UTF-8 format. What can I do?
Reply
#2
Hi Pverbeek,

Please try the following:

- Ensure database is set to utf8_general_ci
- Check your /global/config.php file doesn't contain a $g_unicode = false; line and your /global/library.php does contain a $g_unicode = true; line (unicode is enabled by default, so unless you edited it this should be fine).
- Encoding of form is set in metatag in the header of your form document, please add this meta tag to your form: <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
- In the form tag add "accept-charset="UTF-8" to the form <form ... accept-charset="UTF-8">

Cheers,

Joe
Reply
#3
Hi Joe,

many thanks for your Reply. The last tip, you gave me, solved the problem, the other definitions were already okay, but in the form tag was defined as "iso"

I have another problem and since you seem to know al lot about php, I ask you directly: How can I set some fields as obligation to fill in? I had those fields marked as "required" but Form Tools erased those specifications. So I suppose, there must be an other way. Can you help me?

Many thankt in advance.

Peter Verbeek

(Nov 20th, 2013, 10:35 AM)Joe Wrote: Hi Pverbeek,

Please try the following:

- Ensure database is set to utf8_general_ci
- Check your /global/config.php file doesn't contain a $g_unicode = false; line and your /global/library.php does contain a $g_unicode = true; line (unicode is enabled by default, so unless you edited it this should be fine).
- Encoding of form is set in metatag in the header of your form document, please add this meta tag to your form: <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
- In the form tag add "accept-charset="UTF-8" to the form <form ... accept-charset="UTF-8">

Cheers,

Joe

Reply
#4
Hi there,

You should check out: http://docs.formtools.org/tutorials/js_v...e=rsv_file

Cheers,

Joe
Reply
#5
Hi Joe,

seemst to be exactly, what I need and searched for!

Thank you and have a nice weekend, I will try to implate these rules in my form and let you know.

Bye, Peter
Reply
#6
Bonjour !
I have (maybe) the same problem with sending mails and was happy to find a solution here - but this does not work for my problem:

It seems to me that mails (neither client nor administrator notification) will be send if their are special characters like the german äöüß or the french éèàâ in the client/administrator name (last name and/or first name).
For the administrator-name it's a minor problem - I have removed the 'ö' from my last-name, but how to deal with client-names?

I'm using the 2.2.5 version and my provider is 1and1.fr

Thanks in advance
Martin
Reply
#7
Check your /global/config.php file doesn't contain a $g_unicode = false; line and your /global/library.php does contain a $g_unicode = true; line (unicode is enabled by default, so unless you edited it this should be fine).
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)