FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Form Tools 3 alpha available!
#1
Well hello everyone! Long time no speak! 

This weekend I released a first version of Form Tools 3, which you can download here as an alpha. I wrote up a quick post about it yesterday, but thought I'd say a few more words here. Form Tools 3 is a complete rewrite of Form Tools - but on the surface, will appear virtually identical to Form Tools 2. I know that's not the most exciting of things in the world, but it was a necessary one. The one concrete improvement in FT3 is adding support for PHP7 (long overdue!) but having a cleaner, better organized codebase will be beneficial for years to come. 

In the short term, I'm focusing on the following:
  • updating each and every module and theme for FT3 support. Yesterday I fixed up the Classic Grey theme and today I was working on the System Check module. I'm expecting things to move a little faster now that that Core is in alpha.
  • fixing whatever bugs get spotted. 
  • fixing up these forums! Boy, this place needs a good clean up. Lots of poor styling - I'll see what I can do.
  • Bringing the upgrade script back online. 
Please use this forum for any questions/bugs relating to Form Tools 3. I'm going to do my best to monitor and respond. I know I haven't been the best at that, but I'm really going to try to devote a little time each day.

Thanks! 

Ben
Reply
#2
Already installed, with php5.6 mariaDB, sucess Smile

Lovely work Smile
Nelson Costa.
Reply
#3
hi,
When i reconfig EDIT EMAIL TEMPLATE i see the message

Forbidden
You don't have permission to access /formtools/admin/forms/edit/index.php on this server.

can you help me...
Reply
#4
(Sep 18th, 2017, 2:30 AM)nelsondcosta Wrote: Already installed, with php5.6 mariaDB, sucess Smile

Lovely work Smile

Nice! I really need to look at MariaDB more - but great to hear it's compatible. Smile
Reply
#5
(Sep 18th, 2017, 6:33 AM)mjvmst Wrote: hi,
When i reconfig EDIT EMAIL TEMPLATE i see the message

Forbidden
You don't have permission to access /formtools/admin/forms/edit/index.php on this server.

can you help me...

Hmm, that's curious! I wasn't able to reproduce it on my own installation - testing on Chrome + PHP 5.6 / 7.1.1. Does that path look right to you for your own installation? (i.e. is it installed in a /formtools folder on your root?) 

The admin/forms/edit/index.php file is used for editing all the various pages in your form. Do the other pages in the edit form section work (e.g. Main, Fields, View and Emails tabs)? 

You may want to try re-uploading all the files from the alpha just in case.
Reply
#6
(Sep 18th, 2017, 8:03 PM)Ben Wrote:
(Sep 18th, 2017, 6:33 AM)mjvmst Wrote: hi,
When i reconfig EDIT EMAIL TEMPLATE i see the message

Forbidden
You don't have permission to access /formtools/admin/forms/edit/index.php on this server.

can you help me...

Hmm, that's curious! I wasn't able to reproduce it on my own installation - testing on Chrome + PHP 5.6 / 7.1.1. Does that path look right to you for your own installation? (i.e. is it installed in a /formtools folder on your root?) 

The admin/forms/edit/index.php file is used for editing all the various pages in your form. Do the other pages in the edit form section work (e.g. Main, Fields, View and Emails tabs)? 

You may want to try re-uploading all the files from the alpha just in case.

Hello!
Thanks for the feedback.
Regardless of the browser, I always get this error.
Yes the path is from my installation, ...
I've been testing the other pages in the section and the tables work normally. Only the email has this error.
I've reloaded all the files and nothing ...
Reply
#7
(Sep 19th, 2017, 12:26 PM)mjvmst Wrote:
(Sep 18th, 2017, 8:03 PM)Ben Wrote:
(Sep 18th, 2017, 6:33 AM)mjvmst Wrote: hi,
When i reconfig EDIT EMAIL TEMPLATE i see the message

Forbidden
You don't have permission to access /formtools/admin/forms/edit/index.php on this server.

can you help me...

Hmm, that's curious! I wasn't able to reproduce it on my own installation - testing on Chrome + PHP 5.6 / 7.1.1. Does that path look right to you for your own installation? (i.e. is it installed in a /formtools folder on your root?) 

The admin/forms/edit/index.php file is used for editing all the various pages in your form. Do the other pages in the edit form section work (e.g. Main, Fields, View and Emails tabs)? 

You may want to try re-uploading all the files from the alpha just in case.

Hello!
Thanks for the feedback.
Regardless of the browser, I always get this error.
Yes the path is from my installation, ...
I've been testing the other pages in the section and the tables work normally. Only the email has this error.
I've reloaded all the files and nothing ...

Very curious! I looked over the code for that section but nothing looks incorrect or something that could cause that problem. 

I know this is a long shot, but I don't suppose you're running it on a public site somewhere - somewhere where I could FTP in and debug the problem directly? If so, email me at ben.keen@gmail.com and I'll happily take a look. 

Ben
Reply
#8
(Sep 19th, 2017, 8:02 PM)Ben Wrote:
(Sep 19th, 2017, 12:26 PM)mjvmst Wrote:
(Sep 18th, 2017, 8:03 PM)Ben Wrote:
(Sep 18th, 2017, 6:33 AM)mjvmst Wrote: hi,
When i reconfig EDIT EMAIL TEMPLATE i see the message

Forbidden
You don't have permission to access /formtools/admin/forms/edit/index.php on this server.

can you help me...

Hmm, that's curious! I wasn't able to reproduce it on my own installation - testing on Chrome + PHP 5.6 / 7.1.1. Does that path look right to you for your own installation? (i.e. is it installed in a /formtools folder on your root?) 

The admin/forms/edit/index.php file is used for editing all the various pages in your form. Do the other pages in the edit form section work (e.g. Main, Fields, View and Emails tabs)? 

You may want to try re-uploading all the files from the alpha just in case.

Hello!
Thanks for the feedback.
Regardless of the browser, I always get this error.
Yes the path is from my installation, ...
I've been testing the other pages in the section and the tables work normally. Only the email has this error.
I've reloaded all the files and nothing ...

Very curious! I looked over the code for that section but nothing looks incorrect or something that could cause that problem. 

I know this is a long shot, but I don't suppose you're running it on a public site somewhere - somewhere where I could FTP in and debug the problem directly? If so, email me at ben.keen@gmail.com and I'll happily take a look. 

Ben

I tested here, everything works fine Smile

Can you tell me your SQLDB server version and PHP version?
Nelson Costa.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)