FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Clients access Admin account issue
#8
(Sep 28th, 2017, 7:09 PM)Ben Wrote: Hey Tasos,

From what you described it sounds like there's some sort of problem with the session itself. The whole point of sessions is that the unique client-specific session ID gets stored on the single user's computer in the form of a cookie, then passed with all requests back to the server. But somehow that's not working here.

Are you using PHP sessions for Form Tools (it's the default)? Could you try switching to database sessions? It may not fix anything, but it would at least eliminate PHP as the cause. PHP sessions work by creating files on your server for each session. Just wondering if maybe there's a problem there & the session ID is being duplicated somehow... or maybe disk space? Really not sure - but worth a shot.

Just add this to your `/global/config.php` file:


PHP Code:
$g_session_type "database"


Then try logging out + in again. You shouldn't notice any difference: it should behave exactly the same way (but if you're curious, the `{prefix}sessions` table in your database will be populated with session data).

Ben


Hey Ben, 
sorry for the very late reply, but we had some server issues and things got a bit hectic (irrevelant to the issue at hand). That sounds like a good advice and I am going to give it a try, however (better safe than sorry) I do have a question. Should I leave the command as "database" or add the name of our DB "datacom2_ftool10" ? 
Also, look what happened....I created a new cient and everything was Ok, I added a new form and since then the new client started getting mixed up with the other clients and the admin. So, I erased the new client since there was nothing else I could do to fix the issue. 

Thank you for the advice, I am def giving it a try as soon as you let me know if the command should be that way. 

Thanks again, 
Tasos
Reply


Messages In This Thread
Clients access Admin account issue - by datacom - Sep 20th, 2017, 7:45 AM
RE: Clients access Admin account issue - by Ben - Sep 26th, 2017, 8:55 PM
RE: Clients access Admin account issue - by datacom - Sep 27th, 2017, 1:06 AM
RE: Clients access Admin account issue - by datacom - Nov 16th, 2017, 9:33 AM
RE: Clients access Admin account issue - by datacom - Nov 16th, 2017, 9:36 AM
RE: Clients access Admin account issue - by Ben - Sep 28th, 2017, 7:09 PM
RE: Clients access Admin account issue - by datacom - Nov 16th, 2017, 9:43 AM
RE: Clients access Admin account issue - by datacom - Dec 11th, 2017, 7:51 AM

Forum Jump:


Users browsing this thread: 1 Guest(s)