FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Form Tools Core (3.0.0-alpha-20171023)
#1
Appears the data visualization is borked in this release.  I installed a clean copy, and when getting to step 6 in the install, it reports errors related to this extension..

Quote:Warning: require_once(/home/abc123/www/ft3/global/code/Accounts.class.php): failed to open stream: No such file or directory in /home/[b]abc123/www/ft3/global/library.php[/b] on line 6

Fatal error: require_once(): Failed opening required '/home/abc123/www/ft3/global/code/Accounts.class.php' (include_path='.:/usr/local/lib/php:/usr/local/php5/lib/pear') in /home/abc123/www/ft3/global/library.php on line 6
If I remove that extension folder, it completes the installation as expected.
Let me know if you need further information.
Lyle
Reply
#2
Thanks Lyle! Strange, I haven't been having any problems. Let me look it over and see if I can find anything that looks suspect.

Ben
Reply
#3
Hey Lyle, hmm... I've had no problems on my end. What version of PHP are you running?

Does the path look right in that error message you posted? I don't really see how the Data Visualization module is involved to be honest - it would have complained about something in the modules/data_visualization folder, I think.

Also: try adding the module back in with your working installation. Curious to know if you still have problems now.

Ben
Reply
#4
(Oct 29th, 2017, 8:09 PM)Ben Wrote: Hey Lyle, hmm... I've had no problems on my end. What version of PHP are you running?

Does the path look right in that error message you posted? I don't really see how the Data Visualization module is involved to be honest - it would have complained about something in the modules/data_visualization folder, I think.

Also: try adding the module back in with your working installation. Curious to know if you still have problems now.

Ben

Hi Ben,

Found the issue.  In the archive, the following file has a capitol I in the name..

data_visualization/code/FieldCharts.class.php

in the file data_visualization/library.php

So on *nix boxes, it won't see it.  I changed it to lower case, and viola!  Smile

Lyle
Reply
#5
Ah, thanks Lyle! Drat, this didn't even cross my mind from the error...! I've actually already patched this & I'll update the module tonight.

Sorry, and thanks again Smile

Ben
Reply
#6
NP, anytime.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)