FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Warning message with version 2.0.0-beta-20090908
#11
Hi,

Just ran in to a similar set of issues myself upgrading from 20091030 to 20100101 (current version).

Similar error messages to what other posters saw:

Reverting the session_start to the old version seemed to resolve the problem.

So the new version that I downloaded that caused the problems was:

PHP Code:
<?php

$folder 
dirname(__FILE__);
$g_defer_init_page true;
require_once(
"$folder/library.php");

if (
$g_session_type == "database")
  
$sess = new SessionManager();

if (!empty(
$g_session_save_path))
    
session_save_path($g_session_save_path);

session_start();
header("Cache-control: private");
header("Content-Type: text/html; charset=utf-8");

$folder dirname(__FILE__);
require_once(
"$folder/init_page.php"); 

But reverting to the version below has made it work again:

PHP Code:
<?php

$folder 
dirname(__FILE__);
require_once(
"$folder/library.php");

if (
$g_session_type == "database")
  
$sess = new SessionManager();

if (!empty(
$g_session_save_path))
    
session_save_path($g_session_save_path);

session_start();
header("Cache-control: private");
header("Content-Type: text/html; charset=utf-8"); 

Don't know what defer_init_page does - but is it the cause of this issue?
Reply
#12
Drat... I thought I'd buried this issue once and for all. You can tell it's a Monday.

I added in $defer_init_page to solve this very problem - and it's worked on every installation except yours so far, so I'm hoping this is just a matter of a file being out of whack or something.

I don't suppose I could get temporary access to your site so I could debug this directly? No worries if not. If it works, it works; I'm just concerned about whenever you choose to upgrade. It could mess things up in the long run.

- Ben
Reply
#13
Ben - please see PM.

Thanks

(Jan 18th, 2010, 11:17 AM)Ben Wrote: Drat... I thought I'd buried this issue once and for all. You can tell it's a Monday.

I added in $defer_init_page to solve this very problem - and it's worked on every installation except yours so far, so I'm hoping this is just a matter of a file being out of whack or something.

I don't suppose I could get temporary access to your site so I could debug this directly? No worries if not. If it works, it works; I'm just concerned about whenever you choose to upgrade. It could mess things up in the long run.

- Ben
Reply
#14
Sorry for the wait, Martin. Will look at this weekend. :-)

- Ben
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)