FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Windows Install Tweak Needed
#1
Hey Guys,

First of all.. this is a fantastic product. I've been using v1 for about 2+ years now and love it. V2 looks even better.. Sooo.. I'm going through the install and have run into a couple things.

First, I'm running it on Win2k Server under IIS and PHP 5.2.8 with MySQL 5.0.51a. (no problems running v1 under this config)

Second, after the i had to double-backslash the root_dir path. (I'm okay for this problem, but just wanted to mention it)

Third, I'm getting the errors below when I try to access the admin page.. The first thing I notice is the path slashes aren't appropriate for windows. I looked through a bunch of the code pages but can't see where I'm missing it.. Could it be in my Pear config?

EDIT - The url shows http://<my site>/form_v2/?message=notify_no_account_id_in_sessions

Code:
Notice: Undefined index: REQUEST_URI in C:\Inetpub\form_v2\global\code\stabilizer.php on line 45

Warning: include(C:\Inetpub\form_v2/themes/default/cache/\%%C6^C68^C68758FD%%index.tpl.php) [function.include]: failed to open stream: No such file or directory in C:\Inetpub\form_v2\global\smarty\Smarty.class.php on line 1258

Warning: include() [function.include]: Failed opening 'C:\Inetpub\form_v2/themes/default/cache/\%%C6^C68^C68758FD%%index.tpl.php' for inclusion (include_path='.;C:\php5\pear;^') in C:\Inetpub\form_v2\global\smarty\Smarty.class.php on line 1258
PHP Notice: Undefined index: REQUEST_URI in C:\Inetpub\form_v2\global\code\stabilizer.php on line 45 PHP Warning: include(C:\Inetpub\form_v2/themes/default/cache/\%%95^95D^95D59E10%%eval.tpl.php) [function.include]: failed to open stream: No such file or directory in C:\Inetpub\form_v2\global\smarty\Smarty.class.php on line 1265 PHP Warning: include() [function.include]: Failed opening 'C:\Inetpub\form_v2/themes/default/cache/\%%95^95D^95D59E10%%eval.tpl.php' for inclusion (include_path='.;C:\php5\pear;^') in C:\Inetpub\form_v2\global\smarty\Smarty.class.php on line 1265 PHP Warning: include(C:\Inetpub\form_v2/themes/default/cache/\%%C6^C68^C68758FD%%index.tpl.php) [function.include]: failed to open stream: No such file or directory in C:\Inetpub\form_v2\global\smarty\Smarty.class.php on line 1258 PHP Warning: include() [function.include]: Failed opening 'C:\Inetpub\form_v2/themes/default/cache/\%%C6^C68^C68758FD%%index.tpl.php' for inclusion (include_path='.;C:\php5\pear;^') in C:\Inetpub\form_v2\global\smarty\Smarty.class.php on line 1258


Thanks for your help!..

Rich Morgan
Reply
#2
Hey Rich,

Brilliant, thanks for the feedback!

Quote:Second, after the i had to double-backslash the root_dir path. (I'm okay for this problem, but just wanted to mention it)

Noted. Somehow I managed to introduced some backslashing weirdness in FT2 what wasn't in the first version. I thought I'd solved it, but somehow it keeps rearing its head. I'll look into this.

For the other problems:
1. REQUEST_URI not being defined is pretty common; I'm surprised I haven't caught that. That error will be gone in the next build.
2. For the path problems, is the /cache folder path correct? (C:\Inetpub\form_v2/themes/default/cache). The direction of the slashes *shouldn't* make a difference, but just in case, edit your $g_root_dir path in your /global/config.php file to

PHP Code:
$g_root_dir "C:/Initpub/form_v2"

Probably won't make a difference, but worth a shot.

Next, does your /themes/default/cache folder contain some files other than emptyfile.txt? Also, is it writeable?

- Ben
Reply
#3
Hey Ben,

Thanks for the quick reply.. and the initiative.

Quote:2. For the path problems, is the /cache folder path correct? (C:\Inetpub\form_v2/themes/default/cache).

Yes, the path does exist and I did change the $g_root_dir path but got the same result and displaying all forward slashes versus the mixed slashes.

Quote:Next, does your /themes/default/cache folder contain some files other than emptyfile.txt? Also, is it writeable?

Yes, there are a bunch of files in the folder, mostly *.tmp files, , about 9 files beginning with "%%" ending with a normal php script name and .php. There is also the "emptyfile.txt" which is writable.

Thanks for your help and let me know if you need anymore info..

Rich
Reply
#4
One other thing - could you just check that both the $g_root_url and $g_root_dir values don't have any trailing slashes in your config.php file (i.e. their last character isn't "/" or "\")? Again, probably won't make a difference - just want to check!

- Ben
Reply
#5
Here's something else you could try, but it involves a bit of brain surgery.

Edit the /global/code/themes.php page and go to line 178. There, you'll find this line:

PHP Code:
$g_smarty->compile_dir  "$g_root_dir/themes/$theme/cache/"

Remove the trailing slash, to make it this:

PHP Code:
$g_smarty->compile_dir  "$g_root_dir/themes/$theme/cache"

Then try going to Form Tools again in your browser. I'm wondering if that final slash is confusing your system - I noticed your error messages contained an extra (incorrect) slash, so that may prevent Smarty from finding the temporary files.

Let me know!
Reply
#6
Hey Ben,

I've got no problem performing brain surgery. :-)
Change made to the trailing slash on the 'cache' path in the themes.php but with the same result (or lack thereof). Also, I did make sure there were no trailing slashes in the config.php file. Just for kicks I tried switch the forward to backslashes on the line below with equally ugly results..

One thing I did notice is in the error page it does show the standard PHP warning (with the correct path structure) and the PHP code errors (with the wrong path structure).. if it helps..

[Image: ft2_1.gif]

I'll keep strolling through the code to see if anything pops out at me... but let me know if you find anything. Thanks Ben!

(Mar 4th, 2009, 3:37 PM)admin Wrote: Edit the /global/code/themes.php page and go to line 178. There, you'll find this line:

PHP Code:
$g_smarty->compile_dir  "$g_root_dir/themes/$theme/cache/"

Remove the trailing slash, to make it this:

PHP Code:
$g_smarty->compile_dir  "$g_root_dir/themes/$theme/cache"
Reply
#7
Thanks, Rich. If you reach the end of your tether and would like me to look at the problem directly, just email me your login URL + FTP info and I'll take a look: formtools@encorewebstudios.com

Good luck!
Reply
#8
I only modified my config file. This is what worked for me, I am using xampp on windows:

PHP Code:
<?php

// main program paths - no trailing slashes!
$g_root_url "http://111.222.33.444//xampp/formtools";
$g_root_dir 

"C:\\xampp\htdocs\\xampp\\formtools";

// database settings
$g_db_hostname "localhost";
$g_db_name "customers";
$g_db_username "root";
$g_db_password 

"";
$g_table_prefix "ft_";

?>
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)