FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
mass edit installation problem
#1
i'm running formtools 2.0.0 beta

i tried to install the mass edit module. downloaded the .tar (and zip) files into the modules directory and extracted. the extraction did not create a "mass edit" folder so i did that separately and moved all the components from the extracted file into it.

it registers, and shows it was "installed" but there is no "mass edit" button showing on the edit page.

any ideas on what to try? the name of the folder i created was "mass_edit

thanks

bill
Reply
#2
Hmmm! What version of the core are you running? You need to be at 2.0.0-beta-20090518 or later.

If you are, what theme are you using? Is it a custom theme that you developed yourself? That may also be the problem.

- Ben
Reply
#3
I'm having this problem too.

I downloaded the "Mass Edit" extension pack >> Unzipped it on my computer >> and FTP'd it to the "modules" directory of FormTools on the server >> I logged into the Admin page >> went to Modules >> Refreshed >> and installed the Mass Edit extension.

The "mass_edit" folder is there with all its contents.
The "Modules" page in the admin section shows its installed yet there is no "Mass Edit" button on any of my form submission pages.

I have core v2.0.0-beta-20091101 installed and I'm using the default theme. Everything is up to date when I check for Updates/Upgrades.

Is there something I've missed to initiate the extension?
Reply
#4
Yeah. That's so weird. I never noticed that feature not being present.
I tried using default themes and they wouldn't render out the Mass Edit button what so ever.

I'm all up-todate. Guh. I'm always having problems! haha.

-Axel
Reply
#5
I'll take a look at this problem tonight. It's possible that I messed something up that prevents the module from working with newer versions.

- Ben
Reply
#6
So? What's the verdict. I attempted to load the page with the theme, but I still can't get it.

What line in the templates drives the Mass Edit button to appear?

-Axel
Reply
#7
Drat - totally forgot about this thread.

Tar file problems

So! First off, regarding the module tar files: they don't work quite as cleanly as the zip versions. This is something I still have to address. Right now when you download a tar file, it will contain a single file: ANOTHER tar file. So you'll need to untar it twice. Second time round you'll see all the files: in this case you'll need to stick them all in a "mass_edit" folder and upload it to your modules folder. That'll ensure that the module is uploaded properly.

plain ain't workin' problems

Hmmmm.... puzzling! There's nothing apparently wrong with the module itself. I did a fresh installation and all looks fine. I also tried testing it on an older version of the Core, and that worked fine too.

Quote:What line in the templates drives the Mass Edit button to appear?

All modules (with the exception of the Export Manager, which uses an earlier, crappier design) add their content to Form Tools pages via Hooks. The idea is that modules should always be totally independent of the Form Tools Core - i.e. the Core should be able to work perfectly well without any module being installed and that upgrading the Core templates won't interfere with modules, even those that are embedding their own content into the Form Tools templates, like with the Mass Edit module. That adds a "Mass Edit" button onto the main Submission Listing page. They add it via "template hooks", as described in the documentation page linked above.

My hunch is that maybe there's a problem with the way the hooks are being registered on your installations, but this is really a bit of a doozy to debug remotely...

If anyone would like me to look at their problem directly, email me at ben.keen@gmail.com with their Form Tools login info and (temporary) FTP. I'd be happy to look into it.

- Ben
Reply
#8
also problem with me, when i click mass edit, it takes me back to the form listening page !!

i guess there is some issue with the script module.
Reply
#9
I'm having the same problem, installed Blank Form and Mass Edit modules. Both none of them shown at all.

I'm upgraded from 2.0.x beta, tried to uninstalled the modules by removing all the files and download the zip again, but still doesn't help.
Oops... forgot to mention now in 2.0.4 , everything is up-to-date. but problem still exists.
Reply
#10
Hi Jackson,

Any possibility I could take a look at this problem on your installation? If so, email me your Form Tools login info & FTP info. I'll see if I can get to the bottom of it!

ben.keen@gmail.com

- Ben
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)