FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
"Check for Upgrades" Button not working
#1
When clicking on the check for updates button on the settings Main Page... I get the message:
This page cannot be called directly. You must click on your "Upgrade" link from your Form Tools installation. This is generally found in the "Main" tab of your Settings pages.

I do see there is a upgrade that I need to apply ....

Thanks!
Reply
#2
Ah thanks, PTTW. Sounds like a bug relating to the site move, I'll check it out.

- Ben
Reply
#3
Damn, this is a shame. I thought the subdomain move went too smoothly...!

Here's the problem: http://ft2.formtools.org no longer exists; it automatically redirects all requests to that location to http://www.formtools.org. The upgrade button submits your Form Tools component versions to the site so it can figure out what's been updated. The thing is, the Form Tools upgrade button links to the ft2 subdomain, so after the server redirects all the POST information is lost.

I'll fix this in the next release for all new installations, but in order for anyone to actually get the new release via upgrading, they'll need to fix this bug manually.

You'll need to edit your /themes/default/admin/settings/tab_main.tpl file and find this line (line 67):

Code:
<form action="http://ft2.formtools.org/upgrade.php" id="upgrade_form" method="post" target="_blank">

Please change it to:

Code:
<form action="http://www.formtools.org/upgrade.php" id="upgrade_form" method="post" target="_blank">

Then refresh your page and click the upgrade button again.

Again, I'm really sorry about this! I'm going to make this a sticky post & link to it from the news page.

- Ben
Reply
#4
OK.. that got me further... I was able to select the modules that required updates just fine... but in IE I get the message "Warning: mkdir() [function.mkdir]: No such file or directory in /home/.rickardo/benkeen/formtools.org/global/code/upgrade.php on line 347" many many times and when I click on the generate file, the file seems to be generated, however, when I click on the download zip file... I dont get a download.... In Firefox, I do not get the warning message, but the remaining issues are still present....Sorry to be a pain!
Reply
#5
No - not at all! I really appreciate your patience with this. Smile

Try again now. Oddly enough, it worked for me, but I could see a couple of problems in the code.

- Ben
Reply
#6
It still says the file is generated...but the download of the zip file does not seem to be sent ..nor does it arrive in my download directory... it just hangs with a blank screen on the page
http://www.formtools.org/download_file.p...e_b458.zip

in both IE and Firefox
Interesting... It only seems to fail for Form Tools Core .... the other downloads work as they have always worked just dandy!
Reply
#7
Ahhh... thanks for that last tip.

The upgrade mechanism uses on a caching mechanism to prevent creating duplicate zipfiles twice. Try re-clicking the upgrade button. It should work fine now.

- Ben
Reply
#8
works perfect...THANKS
Reply
#9
I've actually been using FT for a while-happily! But I want to upgrade from 1.5.2 to 2.x. I can't find the "upgrade" button anywhere? Is there something else I need to do and once done, my mysql dbs will be intact, right?
Actually 1.5.1 sorry!
Actually 1.5.1 sorry!
Reply
#10
Hah, no worries. Smile

There's no direct upgrade from version 1 to 2 since they're such different scripts, but you can check out this module, which allows you to port data from old versions:
http://modules.formtools.org/ft1_data_import/

All the best -

Ben
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)