The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Swift mailer not installing
Hi Ben,

I added the new Swift Mailer upgrade (1.0.0-beta-20090309) and the new core upgrade (2.0.0-beta-20090309). I refreshed the modules and I tried to install Swift Mailer and I get a blank page at this point:


I looked at my error logs and there's nothing to report. At the same time it didn't install, so I'm not sure what I might be doing wrong.

Thanks for your help.

Hmm... curious! I just downloading it and installing it on my own setup and all seemed to go well.

Most likely, one or more of the files either didn't make it through FTP, or got corrupted en route. Try uninstalling the module (if the "UNINSTALL" link appears on your modules page), then completely deleting the folder. Then, re-download the file and try installing it again.

It's still perfectly possible it's a bug, but I'd like to eliminate the obvious first. Let me know how it goes!
Having exactly the same problem -- and a blank screen.

I deleted, re-downloaded and tried to re install but same issue.
Hey Ben,

Just to let you know I did all of that and more. I posted the link here: I know it's not the place for it, but it was under the topic of email attachments.

If you want, I can give you FTP access to the form, maybe you might able to find the problem. I can also give you access to the admin panel of the form too. Please let me know if you want these.

Hi there -- any news on swiftmailer? Still can't seem to get past the blank page when I install OR uninstall. I've followed all the directions so far, but no love for me. Any help would be VERY appreciated, as I am setting up my website to send out attached files - and it seems swiftmailer is the way to go.
I'm still waiting for Ben to shed some light on this issue. I did all I could, but still no joy for me too.
I did some more test and I hacked the install by going directly into the FT database. There are two options in the modules table to install and enable the module (not sure if it's ok to do this). The two fields are named as follows: 'is_installed' and 'is_enabled'. Initially they were set to 'no', so I edited these two fields and set them to 'yes'. I went into the modules feature in FT and it mimicked an install, however when I clicked on the 'SELECT' link under this module, I get the following error message:

Parse error: syntax error, unexpected '{' in /site/ on line 91

I don't think this is the correct way to do it or it could mean that this could be the initial problem from the start. Interesting ...
Sorry I haven't been able to look at this guys, I've been absolutely swamped with work. I'll put aside an hour to check this out later today. Keep you posted.
Well I'm pretty stumped... I've tried a number of different things: fresh installs, upgrades from older versions - everything works fine.

I don't suppose either of you would mind sending me your Form Tools login info + FTP info? I could debug the problem directly.

I'm kinda out of ideas!
Hi Ben,

Thanks for your reply.

I can send you the FTP details, etc. to your email address. You should receive it soon. Thanks for this.

Turns out this problem is caused by an incompatibility with PHP 4. The module was only supposed to run on PHP 5 right now, but the blank screen issues you guys have encountered is an unintentional side effect.

As I mentioned to you, Tony, I'm going to be overhauling the function for the bug fixes + for PHP 4 support. It won't be any time in the immediate future, but I'll keep you posted here in the forums.

- Ben

Forum Jump:

Users browsing this thread: 1 Guest(s)