FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can not add form due to fatal error
#1
Hello everyone, I am trying to add a simple form with direct method.
whenever i proceed after 4th step, it gets stuck and gives fatal error:

Fatal error: Maximum execution time of 60 seconds exceeded in C:\wamp\www\formtools\global\code\general.php


Is this any bug or my mistake?
Please tel me.

Thank you
Reply
#2
Hi Gangesh,

How large is your form? 60 seconds is a very long time for a form submit - even on that page, which is sending a great deal of data.

It's certainly not your mistake, so I'd classify this as a bug. However, it may well be being caused by some server idiosyncracy.

I don't suppose it would be possible for you to give me Form Tools & FTP access so I could log in and see the problem myself? If it is, email me at ben.keen@gmail.com.

- Ben
Reply
#3
Really appreciate your quick reply.
I am running it on wamp server with all permissions to the files.
and form is real small ..just five fields. So that's why I said may be it can be my mistake.
Is running it on local server can be a problem?

Thanks
Reply
#4
Hi Gangesh,

No, that shouldn't be a problem at all - I do my local dev work on a WAMP server too.

Interesting..... I remember encountering a problem like this before, but I can't for the life of me remember the cause. Drat.

How's your PHP? We'll have to do some debugging. Specifically, you'll need to examine these three functions:

PHP Code:
// reorder fields
ft_reorder_form_fields($_POST$form_idtrue);

// update their values
ft_set_form_database_settings($_POST$form_id);

// delete unwanted fields
ft_delete_form_fields($_POST$form_id); 

What I usually do for something like this is find each function (they'll be defined in /global/code/fields.php and /global/code/forms.php) and add a line like:

PHP Code:
echo "working!"

at various junctures in the code, then resubmit the form. When you see "working!" appear, that means the problem spot is AFTER that line. Keep moving around your "echo" line until you find the problem. Low-tech, but it'll help locate the problem and then we can diagnose it further.

- Ben
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)