FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MySQL mode setting
#1
I am getting the following error:
Incorrect integer value: '' for column 'email_from_account_id' at row 1
and searching this forum I found that this issue is being caused by MySQL running in strict mode. I was just wondering what mode MySQL should be set to so that this error and possibly others do not occur?
Reply
#2
Hi Scott,

I believe MySQL Strict Mode is just an on/off option, so it just needs to be turned off. However, I do realize that some hosting environments won't let you do this, so I consider this a bug. I've already logged it here:
http://bugs.formtools.org/index.php?cmd=view&id=170

I'll actually be releasing 2.0.0 final today, but I'll address this in the next core build.

- Ben
Reply
#3
(Jan 30th, 2010, 10:26 AM)Ben Wrote: Hi Scott,

I believe MySQL Strict Mode is just an on/off option, so it just needs to be turned off. However, I do realize that some hosting environments won't let you do this, so I consider this a bug. I've already logged it here:
http://bugs.formtools.org/index.php?cmd=view&id=170

I'll actually be releasing 2.0.0 final today, but I'll address this in the next core build.

- Ben

Ben thanks for getting back to me. There are actual options that can be set for the mysql mode setting within the my.ini file. I was able to get things working by just remarking out the mode setting and letting it take the default. I'll try a few of the different settings and see which one works best.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)