FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Checkbox probleme
#1
hi !

I've just tried form tools, and looks very good.
I have tried with a form with 2 field, name and email, and 2 checkbox.
It's a question, and you can choice 1 or 2 of the checkbox.

But in the formtools administration, i can see the ID, name, email, and date and IP. but no column of checkbox.

I have try to see in this forum a message like me, but or i havent see it, perhaps ! sorry if this is the second post.

Bt if anyone can help, it could be great !

My version, is 2.0.0,

thanks a lot.
Reply
#2
Hi Aerostar,

Welcome to the forums! :-)

I think I understand: the main submission listing page (the page that lists all submissions in a table format) only has a few columns by default: I think 4 or maybe 5. You can customize what columns appear by going to Edit Form -> Views tab -> Edit View. A "View" is just a way of viewing your submission information. By default, there's a single View called "All submissions". Edit that, then on the following page, click on the "Fields" subtab. There, click check "column" checkbox next to the field that you want added and save.

Hope this helps!

- Ben
Reply
#3
hi,

ok, thanks to your fast answer !

But the probleme, is that the checkbox, are not checked. Because i have do what you said, and it's ok, but the probleme is the checkbox are not checked, and i can, if i want check it manually.

Curious ? Smile
Reply
#4
Hey AeroStar,

PHP is getting confused by the submission. It dosen't quite get that you are receiving multiple fields from that.

The way around it is in the Form it self.

On your checkboxes, add a [] to the end of the name.

Example:
Code:
<input type="checkbox" name="checkbox[]" value="option1"  />
<input type="checkbox" name="checkbox[]" value="option2"  />

That problem used to drive me crazy! Big Grin
Reply
#5
Sad 
!!!
dont'works !

and more, with the [] it doesn't works the smart field!!!

I'm crazy !!!!!
Reply
#6
Hey AeroStar,

Yes, Axel's quite right about the [] characters - but make sure you only add them to the end of the name if you have more than one checkbox with the same name attribute value. Otherwise the "[]" bit isn't necessary.

Another thing you could check is this. Go to your Edit Form -> Fields tab -> click the "Options" link for the checkbox field. On that page, see what Field Option Group is being used and edit it. Do the VALUES of the checkbox field correspond to the value="" attribute value(s) of your checkbox field? If not, they should!

- Ben
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)