The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SOLVED - Submission Pre-Parser not showing in modules list

I'm trying to install the Submission Pre-Parser in an older installation of Form Tools (client does not wish to upgrade at this time). Form Tools v2.0.2. This is in order to provide them with the Spam Protection technique located on this page:

According to that module's download page, for that version of Form Tools, I'm supposed to install version 1.0.1 of Submission Pre-Parser. See here:

I've downloaded it, unzipped it in my local machine and used FTP to upload the folder (submission_pre_parser) to website/form-tools-directory/modules/submission_pre_parser/

In the Form Tools control panel, I went to the modules section and clicked on the REFRESH MODULE LIST button, as well as the UPDATE button.

Unfortunately, I do not see the module listed there, no matter how many times I click on the button. Permissions are 755 with the modules directory. I've logged out of the control panel and logged back in...nothing. I've tried different browsers...nothing. Browser cache cleared...nothing.

Can anyone lend a hint as to what might be going on? Thanks in advance.
I found the answer, in case it helps anyone: in my case, we had recently moved the site to another server (from a Direct Admin to a cPanel) and I found the config file had the $g_root_dir = setting structured as the old server. Once I corrected that, the module showed up.

I can't figure out why the control panel worked otherwise, though. I would figure something like that would crash the system completely.

Forum Jump:

Users browsing this thread: 1 Guest(s)