FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Export not filtering results
#1
Hi all,

I'm trying to export my data based on the filters setup in a particular view. However, every time I export the data, ALL fields appear in the excel or CSV file. The filter only appears to function for viewing the records online.

Is there a way to export the data based on the filter I've already setup, or, do I need to create a new export type in the export module? If it's the latter, could you give me some direction on creating an export type to include only certain data?

Thanks!
Glen
Reply
#2
Just curious, does anyone else experience the same behavior? i.e. excel export showing all fields, regardless of the filters set up in the view? If so, I'll move on to figuring out a different solution.

Thanks!
Glen
Reply
#3
Hi Glen,

I've never seen or heard of this problem before, myself. It *sounds* like maybe there's a problem with your sessions... the Export Manager pulls all the various View settings out of sessions in order to figure out what to display. I'm wondering if maybe in your case the sessions aren't being stored or accessed...

Huh! If you like, email me your Form Tools login info and I could take a look at the problem directly: ben.keen@gmail.com. I'm pretty busy, but I'll try to look at it tomorrow or Friday night.

- Ben
Reply
#4
You know what's interesting, going on your "session" thought, I created a login for you with limited access to submissions or reports. And guess what? It worked fine! I guess it's just an issue with my admin login.

Once my event is over, I'll send you a login with admin rights so you can poke around.

Thanks for your help, Ben. And, for inadvertently providing a work-around!

Regards,
Glen


(Feb 24th, 2010, 10:04 PM)Ben Wrote: Hi Glen,

I've never seen or heard of this problem before, myself. It *sounds* like maybe there's a problem with your sessions... the Export Manager pulls all the various View settings out of sessions in order to figure out what to display. I'm wondering if maybe in your case the sessions aren't being stored or accessed...

Huh! If you like, email me your Form Tools login info and I could take a look at the problem directly: ben.keen@gmail.com. I'm pretty busy, but I'll try to look at it tomorrow or Friday night.

- Ben
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)