The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
500 Internal Server Error

I'm having a problem accessing the install folder.
Just getting a 500 Internal Server Error - I've tried re-uploading the files, chmod 777 the install directory, etc, etc.

Apache version 1.3.41 (Unix)
PHP version 5.2.6
Latest Forum Tools Build

Hmmm.. you could try chmodding the /themes/default/cache folder to ensure its 777, but you really shouldn't see that error at any time.

When you go to the main Form Tools folder in your browser, does it automatically redirect to the /install folder (and THEN show the error)?

Thanks for the quick reply.

Already tried chmodding the cache folder.

And when I go to the main Form Tools link, there's no redirect - just the same server error.
Before getting into the nitty-gritty of debugging, I'd suggest deleting all the files and re-uploading them. The most likely cause at this juncture is that one or more files failed to get uploaded properly.

Let me know if you get the same error after doing this, then we'll start doing some brain surgery on the script...

Deleted the directory, re-downloaded Form Tools, unzipped, re-uploaded, chmodded themes/default/cache 777 - still the same problem.

I noticed that all the php files in the install directory are missing the closing "?>" tag. Just fishing, but could this be the problem?

Also, just to let you know, I've had the original Form Tools installed and working beautifully in the same account for a few months now.

Thanks again in advance.
Hi there, experiencing the exact same problems, tried everything the OP has tried,

haven't ever installed this before, tried
php 4.4.2, 5.2.5, and 6.0

exact details of the error..

[Thu Mar 19 09:39:35 2009] [error] [client *********] Premature end of script headers: index.php

Error 500: Script Execution Failure

done the delete upload several time.. in binary ascii, uploaded both zipped versions and unzipped them, and pre unzipped..

for testing I chmodd'd all files in the entire directory to 777... still the same error whether I go to
the route folder or to the install folder..

any questions ? (happy to help de-bug this)


Hi... got it working.. just CHMOD'd the entire directory to 755.. and now it works.. except !.. (see new thread)
(Mar 19th, 2009, 7:43 PM)ahoward Wrote: Hi... got it working.. just CHMOD'd the entire directory to 755.. and now it works.. except !.. (see new thread)

Out of interest - I've just installed 2.01 today and had this exact same issue - resolution suggested by op worked.
500 Internal Server Error faces a lot of people and do not know what they can do to find the solution and resolve this issue or error. Also the is writing for our help and get more done with these errors.

Forum Jump:

Users browsing this thread: 1 Guest(s)