FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
no successful test submission, blank php pages and more newbie probs
#1
Hi!

I'm brand new to Form Tools, and if I can make it work, I'll be thrilled.

I created my first form and everything was working fine until I tested out the form and got the (probably dreaded) "Form Tools hasn't received a successful test submission yet."

A half dozen tries and no luck yet.

The only things I have changed on the php is the: path/to/global/api/api.php and the url of the next page, as shown here:

http://docs.formtools.org/tutorials/api_...page=step1
http://docs.formtools.org/tutorials/api_...page_form/

One thing the instructions did NOT make clear were whether the path needs to be the FULL url of the page and the location of the forms, in my case:

http://www.lionrhod.net/books/spell_craft_contest.php
http://www.lionrhod.net/books/spell_craf...thanks.php
http://www.lionrhod.net/forms/global/api/api.php

or


/books/spell_craft_contest.php
/spell_craft_contest_thanks.php
../forms/global/api/api.php

When I try putting in full URLs the php pages comes up blank, but maybe SOME of those need to be full and some partial? I don't know much about .php and I'm lost!

Also, will the form email me when someone signs the form? If not, how do I make it do that? Or is that part of the programming process that I'll come across in the next step?

I WOULD like to receive those emails if possible.

And further, if it doesn't send me emails (and even if it does) how do I retrieve the info?

Thanks!
Reply
#2
Thought I should give you the code I have (at the moment, since I keep changing it around to see what I'm doing wrong)

<?php
require_once("../forms/global/api/api.php");
$fields = ft_api_init_form_page("", "test");
$params = array(
"submit_button" => "submit",
"next_page" => "spell_craft_contest_thanks.php",
"form_data" => $_POST,
"file_data" => $_FILES,
"finalize" => true
);
ft_api_process_form($params);
?>

and the form:

<form action="<?php echo $_SERVER["PHP_SELF"]?>" id="spellcraft_contest" method="POST">

<fieldset>

<label for="name">Name</label>
<input type="text" name="name" placeholder="Your Name" title="Enter your name" class="required"><br>Feel free to use your magickal name if you have one.<br>

<label for="email">E-mail</label>
<input type="email" name="email" placeholder="email" title="your email" class="required email"><br>
Please make sure this is correct, or you won't be able to win!<br>

<label for="fileformat">If you win, what file format do you want?</label>
<select name="fileformat">
<option value="kindle">.mobi</option>
<option value="epub">.epub</option>
<option value="pdf">.pdf</option>
</select><br>

<label for="mailinglist">Join my mailing list?</label>
<select name="mailinglist">
<option value="yesmail">Yes</option>
<option value="nomail">No</option>
</select><br>
(We will never sell or give away your info.)<br>
<input type="submit" name="submit" class="button" id="submit" value="submit" />

</fieldset>
</form>

and the thanks page:

<?php
require_once("../forms/global/api/api.php");
$fields = ft_api_init_form_page();
ft_api_clear_form_sessions();
?>

So far I've tried submitting several dozen times with zero luck. I've also tried refreshing the thanks page before I submit, but that doesn't make a difference.

Any clue what I'm doing wrong?

Thanks again!
Reply
#3
I realize you got spammed over the weekend. Bumping this so someone might see it.

Thanks!
Reply
#4
Have you tried using the entire full path on the line:

require_once("../forms/global/api/api.php");

Something probably like /home/yourusername/public_html/forms/global/api/api.php
Reply
#5
(Dec 1st, 2015, 2:21 PM)alexh Wrote: Have you tried using the entire full path on the line:

require_once("../forms/global/api/api.php");

Something probably like /home/yourusername/public_html/forms/global/api/api.php

Yes, I've tried that. It turns my .php page blank. I've tried a half dozen permutations of that and the only one that doesn't turn the page blank is the way I have it.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)