FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Installation does not confirm MySQL version correctly
#1
I don't know the correct technical terms, but in the installation script the PHP command:
Code:
mysql_get_client_info()

Only gets the version of mysqlnd which is part of PHP and not MySQL.

Thus the script returns:
MySql - mysqlnd 5.0.5-dev - 081106 - $Revision: 1.3.2.27 $ FAIL

No matter what version of MySQL is installed. This happens with PHP 5.3 on OS X Snow Leopard.

In order to get the MySQL version, would need something like this:
Code:
<?php
$link = mysql_connect('localhost', 'user', 'pword');
if (!$link) {
    die('Could not connect: ' . mysql_error());
}
printf("MySQL server version: %s\n", mysql_get_server_info());
?>
Reply
#2
Hey pink,

I've logged this as a bug here:
http://bugs.formtools.org/index.php?cmd=view&id=203

Thanks for the heads up.

- Ben
Reply
#3
Awesome. It was a big headache for me to figure out what was wrong but well worth it.

It seems to be an issue mostly on Macs running PHP 5.3 which is the default.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)