FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Having problems sending form to MySQL db
#1
Hello people.

I apologize upfront, but I'm very new to all this (building my 1st website).
I've used the formmail wizard as far as it can take me, but I'm trying to sent my form to my SQL database. I looked at this http://docs.formtools.org/tutorials/api_...page=step1 but fell at the first as I couldn't locate the 'api.php' it refers to.

In summation, I've posted a form up and it works (sends collected info to my email address), but I want the info to go to my SQL database that I've set up.

Thanks in anticipation.

Dean
Reply
#2
Hi,

So assuming you have installed Formtools, then it'll already be linked to your database.

api.php is stored 'under' the formtools installation so if your website is http://www.yoursite.com then you'll find api.php at http://www.yoursite.com/form_tools/global/api/api.php

Try that and see how far you get. Incidentally, I notice you've used formmail. You might need to chop out some of the formail code in order to get Formtools functioning, but it's all good as Formtools can both store to a database and email the form to you.

Martin

(Mar 16th, 2010, 2:12 AM)jaymundaka Wrote: Hello people.

I apologize upfront, but I'm very new to all this (building my 1st website).
I've used the formmail wizard as far as it can take me, but I'm trying to sent my form to my SQL database. I looked at this http://docs.formtools.org/tutorials/api_...page=step1 but fell at the first as I couldn't locate the 'api.php' it refers to.

In summation, I've posted a form up and it works (sends collected info to my email address), but I want the info to go to my SQL database that I've set up.

Thanks in anticipation.

Dean
Reply
#3
Thanks Martin.
I found the file, but now, as I'm trying the next step, it's asking me to log into formtools as administrator, but first I've got to delete the install files. After I've done that though, the login page has disappeared, and I can't find any other link to the login page (only for the forums).
Probably asking too much, but thanks for your help so far.
Dean
Hmmmmmm. The problem area is the test submission. I think I'm logged on as administrator now, but I can't find the 'forms' page. It's an incredibly difficult site to navigate.
Reply
#4
Hi,

So you should be logging on at a url something like:

http://www.yoursite.com/directory_you_in...s_in/admin

Once you're logged in there, "Forms" is the first thing you'll be looking at.

Let us know how you get on.

(Mar 18th, 2010, 12:47 AM)jaymundaka Wrote: Thanks Martin.
I found the file, but now, as I'm trying the next step, it's asking me to log into formtools as administrator, but first I've got to delete the install files. After I've done that though, the login page has disappeared, and I can't find any other link to the login page (only for the forums).
Probably asking too much, but thanks for your help so far.
Dean
Hmmmmmm. The problem area is the test submission. I think I'm logged on as administrator now, but I can't find the 'forms' page. It's an incredibly difficult site to navigate.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)