FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Not going pass step4
#31
Hey Sammy,

Huh, this problem is a real stickler. Yes, if you wouldn't mind sending along your info, that'd be great. Specifically: your Form Tools URL, database info & FTP info.

Just one thing: I'm out of town at a conference right now and will shortly be heading to New York for a week where I probably won't have internet. So I may only get back to you much later. Sorry about that!

- Ben
Reply
#32
Ben,

New forum member, old Form Tools user. I'm having the same problem with step 4 as others are having in this thread.

1. I've tried the installation using IE/FireFox/Chrome, cleared cookies, played with browser settings, etc.

2. I have downloaded and re-installed your install fix on page 3 of this thread with no success. Still can't get past step 4.

3. Have added the line to my configuration file, global/config.php:
$g_session_type = "database";

Any other advice or updates to the "Step 4" issue?

Thanks for all your hard work!!!
Tom B.
Reply
#33
Hey all,

For anyone encountering this problem, do you have a dollar sign in your database username or password? If so, that causes a problem. I've logged it here (it'll be fixed in the next version):
http://bugs.formtools.org/index.php?cmd=view&id=258

As a temporary workaround, just escape it in your config.php file:

e.g. change this:
Code:
$g_db_password = "my$password";

to this:
Code:
$g_db_password = "my\$password";

- Ben
Reply
#34
Hi all,

Has this been resolved yet? Last I see is the "$" issue with the username. This is not the case with me and I still can't pass step 4.
Reply
#35
Hi Kaifanun,

Apparently not! I don't know what's causing it. The last thing with the dollar signs in the usernames/passwords was one cause - beyond that I don't know.

Any chance I could debug the issue directly on your server? If so, send me an email at ben.keen@gmail.com.

- Ben
Reply
#36
I get a blank screen on step 4 so I am unable to install.
Reply
#37
Same for me.
Ben, I send you by email my ftp info, so I hope you can fix this recurrent issue.
Cheers,
Michel
Reply
#38
Sad 
From the cb-1129.zip package, to make working the transition from step4 to step5, this is what I had to do :
1) copy error.tpl from /themes/default/ to the main folder (otherwhise, error.php cannot find it)
2) move /install/messages.tpl to install/templates/ (it looks just a bit cleaner...)
3) comment the line $g_link = ft_db_connect(); in /install/library.php (I do not know why but this is the main issue...)
4) copy error.tpl and dhtml_pagination.tpl from /themes/deepblue to /themes/classicgrey (not really needed, but maybe to avoid potential problems later...)

cheers,
Michel

Edit: step5 ends up with this error "Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)"
Reply
#39
My previous post is not really helpful, and the installation script is too complex for me to fully debug it.
So what worked perfectly is to delete and clean everything, install the version 2.00 (which has the magic to work), delete the install folder, upgrade to v2.04, and upload the modules.
Kisss & Enjoy !
Michel
Reply
#40
Huh...! Thanks for the post Michel, but if that's true (you need to use 2.0.0 to install properly) - argggghhh!!!!

I'll do a diff on the installation code today and see what's changed. Maybe I introduced a bug somewhere down the line.

- Ben
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)