FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Not going pass step4
#51
(Jan 7th, 2011, 8:27 PM)Ben Wrote: Hi imartinez - and anyone else encountering this problem.

If possible, would you allow me to install the script for you on your system? To do that, I'll need the following info:

- the URL of the folder where you've tried to install it
- the FTP info for your server
- your database information

If this is possible, email it to me at ben.keen@gmail.com and I'll look at it as soon as I can.

Ben

Ben,
A good install went south after logging in as admin. And new installs yesterday were giving me problems as others describe. Waiting 24 and doing again now works! Yesterday I was getting error as below; formtools was redirecting every request giving a 302. Posted this in case it helps.

[root@gauri formtools]# php index.php
Status: 302 Moved Temporarily
X-Powered-By: PHP/5.2.16
Set-Cookie: PHPSESSID=933ed7f020f1e6cdd0be37ace737a8b2; path=/
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Pragma: no-cache
Cache-control: private
Content-Type: text/html; charset=utf-8
Location: http://www.***.com/formtools/error.php

Reply
#52
I also cannot get past step 4 in the installation on the new version.

I have tried many of the fixes listed in the forums without much luck! I had to create the config manually. I get a blank page at first as it continues to load then I get 500 internal server error after a few minutes.

IIS gives the detailed error of:
Module: FastCgiModule Request URL - /formtools/install/step5.php
(CGI is enabled on our end)
Notification: ExecuteRequestHandler Phy.Path \formtools\install\step.5.php

We have verified the "most likely causes" are working on the server and still no go.

The session on the server will drop after a specified time, so I change the session from php to database in the config and library file thinking it is timeing out.

I took out the special characters in the user name and password too. We did the custom download, should we try installing with just the standard download? If need, we can do a remote session. Let me know. Any help is greatly appreciated, Thanks - Eve

Running on:
Windows 8
MySql 5.0.2
Reply
#53
I was able to bypass step 5. In the ft_accounts table, I manually added my admin user name and password. You must however have your password encrypted before you add it manually to the database.

To encyrpt: http://docs.formtools.org/encrypt.php

Rename the install folder or delete it, I just renamed it incase I needed to revert back to it.

From there I was able to log-in and finish configuring the settings.

I still have timeout issues involving the modules. According to Zend, it has to do with the default language listed in the formtools\global\code\languages.php that is causing Severe Slow Query Execution on my server. Anything I figure out on this issue I will post here. If you know how to fix it, please let me know.

Eve


Reply
#54
Hi Eve,

I just responded via email. Thanks for letting me see this problem on your server.

Soo... we finally got to the bottom of this. I'm going to release a new version tonight that includes the fix. It's the tiniest of things: the ordering of calls in the library.php file is incorrect, which can cause errors on some systems.

- Ben
Reply
#55
(Apr 18th, 2011, 7:22 PM)Ben Wrote: Hi Eve,

I just responded via email. Thanks for letting me see this problem on your server.

Soo... we finally got to the bottom of this. I'm going to release a new version tonight that includes the fix. It's the tiniest of things: the ordering of calls in the library.php file is incorrect, which can cause errors on some systems.

- Ben

Hi Ben
I have just installed your latest version (Core 2.06 18/04/11) and have encountered the same problems in not being able to get past step 4... had to manually create config.php then clicking on continue shows
error.php in the URL with a Firefox message

The page isn't redirecting properly. Firefox has detected that the server is redirecting the request for this address in a way that will never complete. This problem can sometimes be caused by disabling or refusing to accept cookies.

Got the same message changing the URL to step5.php

BTW Server is justhost.com with PHP 5.2.11 and MySQL 5.0.91

Appreciate your assistance!

Craig
Reply
#56
I have install &used Explorer v. 7, 8, 9, mozilla, opera and safari

Actually i have installed formtools on numerous servers - offline (WAMP server) & online and i have always installed it and on this stage ie on the 4th stage am always told by the system to just create config.php manually
(Apr 23rd, 2010, 7:36 PM)Ben Wrote: Hey guys,

Yeah, another chap emailed me about this but I just can't reproduce it.

What browser are you guys using? Maybe it's a browser issue...

- Ben

Reply
#57
Hi Victory,

Yeah, you're right about there being something wonky with the file generation; it's definitely not working as it should. But after manually creating it, I haven't had any problems with completing the installation.

Craig - any chance I could try and install it on your system myself? I'd love to debug the problem directly. If so, email me at ben.keen@gmail.com with some temporary FTP info & the URL and folder path to the Form Tools installation.

[btw, I've been re-working the installation script in 2.1.0. There are a number of changes: better error handling among them].

- Ben
Reply
#58
Hey guys,

So in Craig's case, the problem was that the password contained a dollar sign which wasn't properly escaped in the config.php file generation. Bug! If this is what's happening in anyone else's case, you can fix it by adding a backslash before the dollar sign in your /global/config.php file.

$g_password = "my\$password";

2.1.0 has much better error handling that 2.0.6, so this won't occur. Also, I'll make sure that passwords are properly escaped upon generation.

Apologies!

- Ben
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)