FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Unable to complete Step 5 creating new form --Fixed
#1
Lightbulb 
I'm trying to add a new form to our list(actually for this site it will eventually replace the only other one in use). I've created numerous forms on numerous sites(including the one giving me errors) without a problem and I have no idea what may be causing this one.

Basically, at step 5, when clicking next, the blue box with "Your form has been completed depending on the number of fields..... etc" pops up for half a second, and then the box shrinks and turns pink as if there is an error, but never populates with any error message. The next page request seems to stop, and the ajax loader graphic just sits spinning.

I wish I could give more information on this, but like I said, the message box just turns pink, has no text in it, and sits unresponsively. If I exit the form setup the form still shows as incomplete on the main list.

Any insight on this would be greatly appreciated

EDIT: I figured out the problem, which was ridiculously simple. Just because there is no indication of exactly what is wrong, I just wanted to share: we installed formtools, then after the fact it was decided to use htaccess to force the www. on urls, the config file was setup as $g_root_url="http://example.com/formtools" and had to be changed to "http://www.example.com/formtools", not sure why the rest of the formtools script worked properly and it only caused a problem with this step, every other function we've used since this site went up has worked fine, except step 5 in adding a new form.

Hope that helps anyone who runs into an empty mystery red box on that step
Reply
#2
Huh... very interesting. I've logged this as a bug, just in case. I'd like to investigate it because it may well relate to another bug that I couldn't reproduce.
http://bugs.formtools.org/index.php?cmd=view&id=225

Thanks very much for the post!

- Ben
Reply
#3
I just had this same problem occur, and the fix was the same. If you'd like to see a screenshot of the error (with the blank red error box), it is here: http://grab.by/H4Gk
Reply
#4
We are having a similar problem on a new installation. Get to step 5, and when formtools attempts to connect back into the web form to complete the installation we receive a message that some of the form fields do not exist. See screen shot here:

https://tinyurl.com/pcq2wbl


[SOLVED] - the solution was to target the exact html file for the FORM URL when initially setting up a new external form in formtools, not just the parent directory. But why? Web browsers can figure out that http://example.com/form/ really means http://example.com/form/index.htm
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)