FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Bug?] characters in uploaded filename breaks display/link in view
#1
As above. I have user called André (no html allowed here I see) upload a file with his name in the filename. The view in FT shortens the filename at the offending character ("CV-Andr"). Upload went fine, it's just that we cannot acces it from the FT installation. Apparently these characters aren't being escaped properly. Anyone care to shine some light on this? Ben?!
Reply
#2
Hi Nowton,

Yes, this looks like a bug. I looked at the code and all it does is strip out whitespace. Instead, it should contain a whitelist of acceptable characters. Probably just a-Z, 0-9, _ and -. I've listed it here:
http://bugs.formtools.org/index.php?cmd=view&id=229

I'll include a fix for this in 2.0.1.

Thanks!

- Ben
Reply
#3
(May 15th, 2010, 9:55 AM)Ben Wrote: Hi Nowton,

Yes, this looks like a bug. I looked at the code and all it does is strip out whitespace. Instead, it should contain a whitelist of acceptable characters. Probably just a-Z, 0-9, _ and -. I've listed it here:
http://bugs.formtools.org/index.php?cmd=view&id=229

I'll include a fix for this in 2.0.1.

Thanks!

- Ben

Thanks for acknowledging this. How would I go about updating this installation? The built-in updater does not find a new build. Thanks.
Reply
#4
Hi Nowton,

Really? When you click on the "Check Updates" button you should get redirected to the Form Tools site. There, at the top right you should see a button labeled "Show Beta Versions" (or something like that). After you click it, you should see the latest Core beta build & be able to select it.

No luck?

- Ben
Reply
#5
(May 18th, 2010, 6:46 AM)Ben Wrote: Hi Nowton,

Really? When you click on the "Check Updates" button you should get redirected to the Form Tools site. There, at the top right you should see a button labeled "Show Beta Versions" (or something like that). After you click it, you should see the latest Core beta build & be able to select it.

No luck?

- Ben

Thanks, that worked.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)